Support » Fixing WordPress » Unable to click buttons on the floating toolbars, in Chrome 61

  • In the last few days I’ve been encountering the following bug:
    When I’m in the edit post screen and want to edit an image, I click on the image and the floating toolbar appears, as it should. However, when I hover the mouse over it in an attempt to click one of the buttons, it starts flickering and makes it very hard to get to any of the buttons. Even after I magically manage to click a button, nothing happens – the edit button doesn’t open the image edit window, and the alignment buttons don’t align the image.

    The same problem happens to me with adding or editing a link using the TinyMCE buttons: the floating toolbar appears, but doesn’t work.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Hello @leac

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    Thanks.

    Thank you for your quick reply.
    I don’t think this is a plugin or theme issue. It happened to me on 5 different sites, and on multiple PCs.
    Just in case, I followed your advice and chose one of those sites and disabled all plugins and activated the Twenty Seventeen theme, but the bug still persists.
    Thank you.

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Keep all the plugins deactivated and the Twenty Seventeen theme active, and then open your browser’s ‘Console’ log.

    https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    Does anything show there?

    Hello @leac

    -Try adding this to wp-config.php file above the /* That’s all, stop editing! Happy blogging. */ line so it looks like this:

    define('CONCATENATE_SCRIPTS', false);

    Hope this will help.

    Thanks.

    @anevins – Thank you. Forgot to say before, but that’s the first thing I checked, and nothing appears. The console is empty 🙁

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Did you enable ‘SCRIPT_DEBUG’ in your wp-config file before opening the console?

    @wbcomdesigns
    Ok, added that, but no change.

    @anevins I have ‘SCRIPT_DEBUG’ enabled in one of the sites, but I don’t see any error in the console.
    Here is what I see:
    Console screenshot

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Would you be able to re-test that on your browser’s incognito mode?

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    I mean to ask with your browser extensions disabled

    I checked, @anevins, and even in incognito mode with browser extensions disabled the bug persists.
    BUT
    I think I understand where the problem comes from:
    I asked myself how it is that this bug happens to me on all the sites I tried, but it doesn’t happen to you or @wbcomdesigns. And I realized that my sites are all in Hebrew. So I changed the system language to English, and – viola, the bug disappeared!

    So I think the bug is related to something regarding RTL. It’s not something I installed because it happens on an almost clean installation.

    What do you think?
    How can this be checked, and what can be done?

    I changed to a few more languages, and the experiments support my suspicion:
    When I changed to Arabic (an RTL language) – the bug appeared.
    When I changed to German and French – the bug went away.

    Is there any solutions for MCE floating toolbar while site is in RTL language?

    Many people in WordPress development related, Hebrew speaking Facebook groups I’m in experience this buggy behavior. Thankfully some of them have posted ways to overcome the problem. I’ll share the ones I found helpful.

    Regarding links

    • Inserting: Just paste the link on the text you want the link to be. WordPress will turn the text into a link, without having to use the hovering toolbar at all
    • Editing: After clicking the link the toolbar appears. In order to get to the gear button tab twice, and then press the Enter button – that will open the link editing window.

    Regarding Images
    Editing and Aligning: After clicking the image the toolbar appears. Click the desired button *a long click*, and the window will open or the image will be aligned as desired.

    Hi Guys,

    The issue happens to lots of users.. Plz handle it as soon as you can!

    Thanks

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Unable to click buttons on the floating toolbars, in Chrome 61’ is closed to new replies.