WordPress.org

Forums

WooCommerce
[resolved] Unable to checkout for Australia - errors for required fields (10 posts)

  1. tokkilee
    Member
    Posted 3 years ago #

    Currently having issues checking out on (test site) http://amberweinberg.com/clients/mgb/ - it's giving a state / county is required error, even though one is clearly filled out? In fact, it's a dropdown so it's been selected. Anyone else have this issue??

    http://wordpress.org/extend/plugins/woocommerce/

  2. Mike Jolley
    Member
    Plugin Author

    Posted 3 years ago #

    Can you enable guest checkout so we can try it?

  3. tokkilee
    Member
    Posted 3 years ago #

    Sure, done :)

  4. Mike Jolley
    Member
    Plugin Author

    Posted 3 years ago #

    I guess the customisation you have isn't outputting those fields? As a guest I see: http://cl.ly/image/12041x0V1B1b So I would think the address fields are either missing or unexpectedly named.

  5. tokkilee
    Member
    Posted 3 years ago #

    Hmm I haven't named anything - but aren't you getting those errors because you haven't inputted the address in #1? When that address is completely filled out, I'm just getting the state error, see: http://awesomescreenshot.com/09b1463w7b

  6. tokkilee
    Member
    Posted 3 years ago #

    Hmm I re-enabled the address form and it looks like that fixed it....they'll just have to put up now have the address pre-filled.

  7. Mike Jolley
    Member
    Plugin Author

    Posted 3 years ago #

    Hmm I haven't named anything - but aren't you getting those errors because you haven't inputted the address in #1

    I wasn't asked for an address, so it looks like that was why.

  8. tokkilee
    Member
    Posted 3 years ago #

    For me, the error was happening when you already had an address inputted from the account section (see the screenshot I sent, there's an address inputted) but I went ahead and just added the whole form back in which fixed it anyways * shrugs*

  9. Mike Jolley
    Member
    Plugin Author

    Posted 3 years ago #

    For me, the error was happening when you already had an address inputted from the account section

    Even on your screenshot, it doesn't look like there were fields present. The checkout process looks for those fields. If you customised this to not have a form, you'd need to have hidden inputs for the address fields.

  10. tokkilee
    Member
    Posted 3 years ago #

    Ah ok :) good to know, thanks :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic