Support » Plugin: MailPoet Newsletters (Previous) » Unable to change the sender’s name and address

  • Resolved cbe


    I am new to Mailpoet and tried to draft my first newsletter. I added the name of my company in the box relating to the sender’s name and correct email address in the “settings”. But when I tried to send the newsletter to the test email, the name and address that are displayed in the email are not correct. My first name appears instead of my company’s name, which is not too good. Anyone has any idea as to what parameter I should change?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi,
    I don’t know if I can be helpful, but till more serious help arrives let me tell you what I’ve in my Settings.

    Under SETTINGS> BASICS Tab > SENDER OF NOTIFICATIONS – There are 2 blank boxes. In the first one, I have the Company name; in the second one, the contact email address like <>.

    You seem to have done that.
    Other than my Company name, I don’t have my personal Name in any field.

    Where have you added your name in the Settings, that it’s picking up the name?


    Thread Starter cbe


    Dear Tarun,

    Thanks for your message.

    Indeed, I added my company name + email address in the 2 blank boxes that you have mentioned.

    But I have no idea why none of this appears when the email is sent and also how my first name is indicated instead (I don’t remember putting my name anywhere in Mailpoet settings). I imagine that there is another app that is overwriting Mailpoet’s settings, but I don’t know how to solve this.

    Any idea is welcome!

    Best regards,


    Hello Carole,

    I guess you may have also checked SETTINGS > ADVANCED > Reply-to name & email, and it doesn’t have your Name there.

    Other than that, you may be right about something overwriting the MP settings – perhaps the settings that exist if you’re using a 3rd party provider to send emails (under SETTINGS> SEND WITH> Your Website OR 3rd Party Provider).

    Hope you can get this resolved soon. The program works great.

    Kind Regards,

    Thread Starter cbe


    Hello Tarun,

    Yes, I also checked the advanced setting. Same here.

    I am also not using a 3rd party provider. What is even more weird, is that the email address that sends the message does not exist: it is My regular address is I had to create this address, just in case some people reply to the newsletter. Not very convenient!

    Thanks anyway for your ideas!

    Best regards,



    Have you solved your problem?
    I am having the same problem. I can’t save the sender information on the third step of the newsletter.

    I wonder if it’s because I have another smtp plugin setup.

    Please let me know if you solved your problem. Thank you.

    Thread Starter cbe


    Hello Guanyixi,

    Yes the problem is solved. You need to finalize the first newsletter and you will have the option to change the sender’s information. Let me know if it worked for you.



    Hi Carole,

    It worked for me too! Thank you so much for your respond. I would never thought about it myself.

    I hope other people who have the same problem will see this post.


    What do you mean you finalized the first post and then you could change the setting for Sender and “Reply-to name & email” for your newsletter?

    I have finished setting it up, activated it. Tried to edit it 5 times, each time activating it. I even just created a new test blog post which triggered that Newseletter to be duplicated and sent it seems; then I tried to change the name and email settings and still no luck.

    Try this in your DataBase.
    1) Go to “prefix”_wysija_email table.
    2) Update your post row in data base modifing from_email,from_name,reply_email and reply_name to your emails values.
    3) Create a new post.

    • This reply was modified 4 years, 11 months ago by loloclon.
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Unable to change the sender’s name and address’ is closed to new replies.