Support » Fixing WordPress » Unable to Change fonts / get the font-family tag to work

  • trevor.b


    Hi there,

    For the life of me I am unable to adjust the font via css for my wordpress site ( I’ve tried placing it in nearly all the different sections in the website (.entry-content / p-tag / content div / etc), I’ve tried cycling through different fonts and the only one that gets any kind of change is monospace. Font weight affects the type as normal, I just can’t change the font. The css I’m using is:

    [CSS moderated as per the Forum Rules. Please just post a link to your site.]

    I know its going to be something stupid and tiny (it always is with me) any help on this would be greatly appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • themebuilder


    Are you trying to change the font in the post content? That can done by adding

    #content {
    	width: auto;
    	height: auto;
    	background-color: Purple;
    	font-family: "Lucida Grande",Verdana,"Bitstream Vera Sans",Arial,sans-serif;

    This is the font type used in this forum. Did that help? I just added

    font-family: "Lucida Grande",Verdana,"Bitstream Vera Sans",Arial,sans-serif;

    to your CSS #content



    Yes and no. Right now its just dumby text to sake up space so I can visually see it. Since I made the post I haven’t solved the answer but I’ve gotten a bit future with it. Apparently its not an issue with wordpress but an issue with Firefox and windows 7 64 / 32bit.

    On Google chrome / safari the site updates normally when I upload a new css page, or through the inspect window but not in Firefox even if it shows the css tag. The only workaround I’ve come across is using javascript or jqueary to code the proper font, or just to prepare for the generic font via Firefox and to redesign the layout accordingly.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Unable to Change fonts / get the font-family tag to work’ is closed to new replies.