Support » Plugin: File Away » Unable to bulk download

  • I get the error message Zip file could not be generated if I try to bulk download from anywhere on my site

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Please can you help with this?

    Plugin Author thomstark

    (@thomstark)

    Do you have error logging enabled in your wp-config.php? If so, do you see any errors in your error log related to this?

    What are the permissions on the temp folder in the file-away plugin directory?

    Have you checked with your web host to see if the zip library is installed on your server?

    I’m getting the following error in log
    ‘PHP Notice: Undefined index: is_safari in /nas/content/live/cwmtafuhb/wp-content/plugins/file-away/lib/cls/class.fileaway_definitions.php on line 29’

    the permissions on the temp folder are
    owner: read, write & execute
    user/group: read, write & execute
    everyone: read & execute

    and yes both zip and ziplibrary modules are installed on the server

    Plugin Author thomstark

    (@thomstark)

    Thanks.

    Is WP_DEBUG_DISPLAY set to true or false? If, true, set to false and try again.

    You can get rid of that notice in line 29 of class.fileaway_definitions.php by changing the line to:

    $image = !empty($GLOBALS['is_safari']) ? 'b' : '1';

    But it shouldn’t be affecting the bulk download stuff.

    Otherwise, everything looks fine as far as bulk downloads are concerned, but I am unable to reproduce your error.

    To troubleshoot further, open up wp-content/plugins/file-away/lib/cls/class.fileaway_management.php

    Find the function: private function bulkdownload()

    Find these lines within that function:

    
    if(strpos($file, '..') !== false) continue;
    if(strpos($file, '/') === false) continue;
    if(stripos($file, '.php') !== false) continue;
    if(stripos($file, 'wp-config') !== false) continue;
    if(stripos($file, 'wp-admin') !== false) continue;
    if(stripos($file, 'wp-includes') !== false) continue;
    if(is_file(fileaway_utility::dirname($rootpath.$file).'/wp-config.php')) continue;
    if(empty($_POST['loc_nonce']) || !fileaway_utility::verify_location_nonce($_POST['loc_nonce'],$file,array($rootpath,$chosenpath))) continue;
    if(!fileaway_utility::realpath(fileaway_utility::dirname($file),$rootpath,$chosenpath)) continue;
    

    Comment them all out, like so:

    
    //if(strpos($file, '..') !== false) continue;
    //if(strpos($file, '/') === false) continue;
    //if(stripos($file, '.php') !== false) continue;
    //if(stripos($file, 'wp-config') !== false) continue;
    //if(stripos($file, 'wp-admin') !== false) continue;
    //if(stripos($file, 'wp-includes') !== false) continue;
    //if(is_file(fileaway_utility::dirname($rootpath.$file).'/wp-config.php')) continue;
    //if(empty($_POST['loc_nonce']) || !fileaway_utility::verify_location_nonce($_POST['loc_nonce'],$file,array($rootpath,$chosenpath))) continue;
    //if(!fileaway_utility::realpath(fileaway_utility::dirname($file),$rootpath,$chosenpath)) continue;
    

    Save. Then try a bulk download. If it works, uncomment one line at a time, save, retry bulk download, and repeat, until it doesn’t work again. Narrow it down to find out which one (or more) of these lines are preventing the bulk download from working.

    It will likely be one of these two:

    
    if(empty($_POST['loc_nonce']) || !fileaway_utility::verify_location_nonce($_POST['loc_nonce'],$file,array($rootpath,$chosenpath))) continue;
    if(!fileaway_utility::realpath(fileaway_utility::dirname($file),$rootpath,$chosenpath)) continue;
    

    If that’s the case, we will have further troubleshooting to do. Let me know your results.

    Or … if you want me to troubleshoot for you, send an email to fileaway.plugin@gmail.com

    I have tried setting the WP_DEBUG_DISPLAY to false with no success and I have tried the troubleshooting, when the lines are commented out I am getting no message at all when I try to download and it is not downloading however it is this line that is causing the error message.

    if(empty($_POST[‘loc_nonce’]) || !fileaway_utility::verify_location_nonce($_POST[‘loc_nonce’],$file,array($rootpath,$chosenpath))) continue;

    I did send an e-mail to fileaway.plugin@gmail.com but got no response.

    thank you for your help, hope we can solve this.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.