WordPress.org

Support

Support » Plugins and Hacks » Unable to build site map with W3 Total Cache on

Unable to build site map with W3 Total Cache on

  • NudeSensuality
    Member

    @nudesensuality

    Hi!

    I have installed both Google XML Sitemaps and W3 Total Cache.

    Everything was working just fine for a while but now i can no longer build my site map.

    When i try to build the map manually i get an error message coming from W3 Total Cache.

    The script is trying to allocate memory but as i’m on a shared server, I only have 64Mb and cannot increase that limit.

    Is there a way to make things work with the settings i have now?

    Or maybe is there a way to tell W3 Total Cache not to cache the sitemap?

    At the moment if i want to build my sitemap, i have to disable W3 Total Cache build then reenable it… That’s inconvenient as i have scripts that post content from rss feeds…

    Thnaks a lot

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Frederick Townes
    Member

    @fredericktownes

    Are there errors in your error log?

    NudeSensuality
    Member

    @nudesensuality

    This is what i get when both plugins are enabled:

    The last run didn’t finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    The last known memory usage of the script was 60MB, the limit of your server is 256M.
    The last known execution time of the script was 25.87 seconds, the limit of your server is 120 seconds.
    The script stopped around post number 20853 (+/- 100)

    If i disable the W3 Total Cache then it’s working perfectly fine…

    Is there any specific log you would want info from?

    Thanks

    Plugin Author Frederick Townes
    Member

    @fredericktownes

    Are you still having this issue after upgrading to the latest W3TC version?

    NudeSensuality
    Member

    @nudesensuality

    Yes, i’ve updated to the latest version of both plugin and i still have the same issue…

    Let me know if there’s anything i can do to help sort this out…

    Cheers

    gooma2
    Participant

    @gooma2

    has anyone been able to find out a solution other than constantly deactivating W3TC? All my sitemaps are being seen as HTML by Google Webmaster tools when W3TC is on, but once I turn it off, all good.

    After all this time, there’s got to be an answer to this one.

    sarbjitarora
    Member

    @sarbjitarora

    Same issue here.

    The sitemaps show up properly if I disable W3TC plugin. As soon as I turn it back on, the sitemaps start showing 0 URLs.

    Plugin Author Frederick Townes
    Member

    @fredericktownes

    I either need someone to submit a bug submission form or provide more details on any errors they’re seeing beyond the issue description.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Unable to build site map with W3 Total Cache on’ is closed to new replies.