Support » Networking WordPress » Unable to Automatically Update with Multisite

  • Resolved nbweaver


    When I try and update automatically through the dashboard, it attempts to update and go to the next screen, but nothing happens. I saw via the codex to try and find the . .maintenance file but I don’t see one in my FTP. I think there is something else causing the automatic update to get hung up. Any suggestions or help would be amazing.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Grab the URL it’s stuck on.

    It’s got a number at the end, right? Change that up by ONE number (so turn 4 to 5, or whatever). Hit enter. What happens?

    This is the url ending it gets hung up on. update-core.php?action=do-core-upgrade

    Oh! CORE. I thought you meant the ‘update network’ option. My bad.

    This one is a ‘check your error log for details’ alas. You may be running out of PHP memory.

    I already tried increasing the PHP memory. I increased it to 128mb in the php.ini

    And did you check your error log?

    This may be a dumb question but where do i go to find that.

    Not dumb 🙂

    If you have cPanel, go in and look for Error log.

    Have that page open, try the upgrade, hit refresh. See if anything pops up.

    No luck. The error log doesn’t show anything new.

    G’Day nbweaver,

    I think you may be having a similar issue to me. Are you getting a 404 Page not found error instead of the Network Admin Dashboard?

    Can you get to the Network Admin Dashboard?

    G’Day nbweaver,

    I found and fixed my problem, with luck it may also fix yours.

    In your FTP program go into the folder wp-content of your blog.

    Check the permissions of the folders network and user. Mine were 757. Change them to 755. There is probably a right-click menu in your FTP tool to allow you to change permissions.

    I think the host is preventing access to a folder with world write permissions which is correct.

    Good luck.

    No, I am not getting a 404 Page not found error.
    Literally just a white page.

    G’Day nbweaver,

    The old White Screen of Death…

    Describes a number of potential solutions for you. I have had this one before and the last solution in this blog post solved the issue for me then.

    There is way of deactivating all your plugins other than via the Admin Dashboard or the MySQL database, just rename the plugins folder (in the wp-contents folder) to anything else. I usually add ‘old-‘ in front of any files/folders I rename so I know what they were called if I want to go back again.

    Ok, maybe I was a little to vague. I still have the dashboard side-bar and I can click away from the update screen its just that the areas where the core update takes place and you it tell you that your site has been updated is basically all white.

    This is not the white screen of death as I understand it…

    Correct, not WSoD.

    However Mr Bearly is right. Time to turn off all your plugins and try the upgrade again. or resign yourself to manual :/

    G’Day nbweaver,

    Since we can’t see what you are looking at it may help if you supply a screen shot of the almost blank page and the full URL of that page.

    What you are describing seems more like a failure to find the body component of the page. It has the header, navigation and footer so as far as WP is concerned there is no error to report.

    Update-core.php is a very busy page of code. It is very robust but it may have been corrupted so it looks as though you may have to do a manual upgrade this time.

    You could try a sneaky trick, using your ftp program upload just a clean copy of update-core.php into your wp-content/network/ folder. If it is corrupted this should fix the problem.

    Rename the old one first in case there is no change in which case you should revert to the original file.

    At worst you end up having to do a manual install of WordPress.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Unable to Automatically Update with Multisite’ is closed to new replies.