[resolved] Unable to Automatically Update with Multisite (24 posts)

  1. nbweaver
    Posted 4 years ago #

    When I try and update automatically through the dashboard, it attempts to update and go to the next screen, but nothing happens. I saw via the codex to try and find the . .maintenance file but I don't see one in my FTP. I think there is something else causing the automatic update to get hung up. Any suggestions or help would be amazing.

  2. Grab the URL it's stuck on.

    It's got a number at the end, right? Change that up by ONE number (so turn 4 to 5, or whatever). Hit enter. What happens?

  3. nbweaver
    Posted 4 years ago #

    This is the url ending it gets hung up on. update-core.php?action=do-core-upgrade

  4. Oh! CORE. I thought you meant the 'update network' option. My bad.

    This one is a 'check your error log for details' alas. You may be running out of PHP memory.

  5. nbweaver
    Posted 4 years ago #

    I already tried increasing the PHP memory. I increased it to 128mb in the php.ini

  6. And did you check your error log?

  7. nbweaver
    Posted 4 years ago #

    This may be a dumb question but where do i go to find that.

  8. Not dumb :)

    If you have cPanel, go in and look for Error log.

    Have that page open, try the upgrade, hit refresh. See if anything pops up.

  9. nbweaver
    Posted 4 years ago #

    No luck. The error log doesn't show anything new.

  10. Mr Bearly
    Posted 4 years ago #

    G'Day nbweaver,

    I think you may be having a similar issue to me. Are you getting a 404 Page not found error instead of the Network Admin Dashboard?

    Can you get to the Network Admin Dashboard?

  11. Mr Bearly
    Posted 4 years ago #

    G'Day nbweaver,

    I found and fixed my problem, with luck it may also fix yours.

    In your FTP program go into the folder wp-content of your blog.

    Check the permissions of the folders network and user. Mine were 757. Change them to 755. There is probably a right-click menu in your FTP tool to allow you to change permissions.

    I think the host is preventing access to a folder with world write permissions which is correct.

    Good luck.

  12. nbweaver
    Posted 4 years ago #

    No, I am not getting a 404 Page not found error.
    Literally just a white page.

  13. Mr Bearly
    Posted 4 years ago #

    G'Day nbweaver,

    The old White Screen of Death...


    Describes a number of potential solutions for you. I have had this one before and the last solution in this blog post solved the issue for me then.

    There is way of deactivating all your plugins other than via the Admin Dashboard or the MySQL database, just rename the plugins folder (in the wp-contents folder) to anything else. I usually add 'old-' in front of any files/folders I rename so I know what they were called if I want to go back again.

  14. nbweaver
    Posted 4 years ago #

    Ok, maybe I was a little to vague. I still have the dashboard side-bar and I can click away from the update screen its just that the areas where the core update takes place and you it tell you that your site has been updated is basically all white.

    This is not the white screen of death as I understand it...

  15. Correct, not WSoD.

    However Mr Bearly is right. Time to turn off all your plugins and try the upgrade again. or resign yourself to manual :/

  16. Mr Bearly
    Posted 4 years ago #

    G'Day nbweaver,

    Since we can't see what you are looking at it may help if you supply a screen shot of the almost blank page and the full URL of that page.

    What you are describing seems more like a failure to find the body component of the page. It has the header, navigation and footer so as far as WP is concerned there is no error to report.

    Update-core.php is a very busy page of code. It is very robust but it may have been corrupted so it looks as though you may have to do a manual upgrade this time.

    You could try a sneaky trick, using your ftp program upload just a clean copy of update-core.php into your wp-content/network/ folder. If it is corrupted this should fix the problem.

    Rename the old one first in case there is no change in which case you should revert to the original file.

    At worst you end up having to do a manual install of WordPress.

  17. nbweaver
    Posted 4 years ago #

    Before I got this page again today, I deactivate all the plugins and tried to update again with no luck.

    I also tried adding the update-core.php file through my FTP and that didn't fix it either.

    Here is a link to a screen shot of the page with the full url. I have done manual core updates in the past to get by, but I'd really like to figure out what is causing this to happen.

  18. Without any PHP errors, it's really hard to say :(

    You could try turning debug on: http://codex.wordpress.org/Editing_wp-config.php#Debug

  19. Mr Bearly
    Posted 4 years ago #

    OK, I have had a look at your site from the outside and it looks very nice. You have 5 sites set up?

    Have you run the updates page to update the network of blogs?

    I also crawled over my version of update-core.php but cannot see where this could be failing.

    As Ipstenu says some php errors would help see where this is crashing out. I suspect that there is a linking problem. Somewhere there is a link URL which is incorrect but it could just as easily be a fouled up MySQL call.

    If it is a MySQL call which is failing then bringing the network up to date 'should' fix it.

    One of the beauties of WordPress is that you can completely delete ALL the folders, re-install them and it will work fine. But you will need to backup the core part of the install.

    This is really only .htaccess the config.php file and wp-content directory. Everything else is essentially a standard WordPress install.

    Because I don't trust computers at all I would also backup the entire MySQL database before I tried this out so I could restore it in the event of a failure.

    You may find that you have to back up the database in bloks rahter than all in one go, they can get pretty big.

    Good luck with all that. There is a fix here, we just have to find it.

  20. Nicholas Weaver
    Posted 4 years ago #

    Ok so I didn't really figure out what the issue was since we last visited this thread a few weeks ago. With 3.4 being released yesterday, I did a manual install of 3.4 and that worked fine. Once I was running 3.4 I decided to try and click the Re-install now button.

    The very same issue I had previously is occurring. I am not able to update or re-install automatically.

    I turned on the debugging and I got a screenshot that looks like this: http://cl.ly/3M3W2e0K0o0D1Q3s1T1Q

    Im not sure what to do next?

    by the way, I am Nbweaver, I just changed my username.

  21. You have a bad theme for one, but you don't have the 'same' error (you actually have an error message now, where as last time you said it was a blank white screen).

    Actually ... Given the errors with the theme, I wonder if that's all related.

    Change the main site's theme to Twenty Eleven, try again?

  22. Nicholas Weaver
    Posted 4 years ago #

    I changed the Theme to Twenty Eleven and the automatic update worked perfectly! sigh!

  23. There you go then. Theme daftness :(

    What theme is this?

  24. Nicholas Weaver
    Posted 4 years ago #

    The theme is "Show Off Beta" by Bio Themes. I should know better then to use an unsupported theme by a company which no longer exists, but it looks and does does exactly what I need it to do. I guess I know where my problem lies now at least.

Topic Closed

This topic has been closed to new replies.

About this Topic