Support » Fixing WordPress » Unable to admin plugins. cannot add, activate or deactivate

  • Existing wordpress site that’s new to me.

    When I enter the dashboard, the only options I have for administering plugins are the Edit view, where I can actually edit the code for any existing plugin. There is no Add New option, or the main Plugins index page. In fact, if I try to access …./wp-admin/plugins.php by typing the url, I get a page that says “You do not have sufficient permissions to access this page.” I need to add a new plug in, so I’m struggling to figure out how to get it back to “normal”, or, how to manually activate/deactivate plugins. I do have some php skills, but have never done any custom wordpress development before, so just looking for a starting point.

    I read that multi site feature can impact an admin users ability to modify plugins, etc, but this site is not using that feature. Also, I’ve read that custom themes can also impact the admin area. I know that this site is using a custom theme based on the Genesis framework. And that’s as far as I’ve gotten in figuring this out.

    Thanks in advance for any pointers in where to start looking to figure this out.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Yes, via FTP, you can reset the plugin folder which may fix that problem:

    I ssh’d into the server, and moved all the existing plugins into a temporary directory I created. Then reloaded the admin section, and the plugins menu had completely disappeared! I tried to hit the admin plugins index page directly, and still got the permissions error.

    So, I moved the plugins back to the plugins directory and back to where I started; still no available options for adding new, activating or deactivating. I’m more convinced this is related to the custom theme. Is there some api calls I should be looking for in the theme’s functions.php file that might provide some clues? Based on my limited wordpress knowledge and the research I’ve done, it seems that would be a good place to start, but looking it over, I’m not seeing anything that leaps out, like a call to something like “suppress_admin_menu_for_some_stupid_reason”… 😉

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Unable to admin plugins. cannot add, activate or deactivate’ is closed to new replies.