Support » Plugin: The Events Calendar » Unable to add widgets

  • Hello,

    I would like to know why, when the plugin is activated, it prevents me to add widgets in the sidebars?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hey @korygans,

    Thanks for using The Events Calendar, and for your patience with my delayed reply, I’m happy to help! This is an unusual issue for sure! In order to help, I would like to get some more information from you, if I can:

    -First, if you could please test for conflicts by following this documentation? Let me know what you find. This will help me determine how deeply we need to look into the specific configuration of your site, or if this is a bug. 🙂
    -Can you send me a link to your site so I can see this firsthand? I’m a visual person, and I can often be more helpful in giving solutions to problems I can see and interact with.

    Thanks!
    Shelby 🙂

    Hello and thank you for contacting me.

    I followed the procedure “Test if there is a conflict” and the problem still persists by activating the theme “Twenty Sixteen” and disabling all the plugins install except the plugin “The Events Calendar”.

    My problem disappears only when it is disabled.

    Small precision when the plugin “The Events Calendar” is enabled all other plugins are working properly. My problem is in the WP Admin > Appearance > Widgets and all my widgets no longer add their button.

    Plugin Contributor Clifford Paulick

    (@cliffpaulick)

    @korygans,

    On my local testing site running the latest versions of The Events Calendar plugin, Twenty Sixteen theme, WordPress core, and no other plugins active, I do not have any such issues (i.e. I cannot replicate this).

    Could you please provide a screenshot of your widgets screen and each widget’s settings when The Events Calendar (TEC) is deactivated?

    Then activate TEC and look for any console errors when at your wp-admin Widgets screen.
    (If needed, you may reference our KB article Using Google Chrome Developer Tools.)

    Please also enable WP_DEBUG and share any PHP errors you see.

    You’ll need to edit to your site’s wp-config.php file and change this line of code: define('WP_DEBUG', false); to this: define('WP_DEBUG', true);
    (or add this line of code if you can’t find mention of ‘WP_DEBUG’ in your wp-config.php file)

    Let us know what you find. 🙂

    This is actually quite a common issue. It has happened with many people – if you read the forums – and a wide range of themes, including Studiopress. It’s a pity it can’t be resolved, because the calendar was a great plug in but this issue is a deal breaker. Numerous people have been frustrated about it for the last several months. I even tried switching themes several times and still the same problem (I disabled all other plugins). Seems like a fundamental problem Modern Tribe should look into. I want to go back to pro version but won’t until this issue is resolved because that’s too much to be paying for no answers and delayed responses. sorry to be harsh but disappointing.

    Hi – I was struggling with this too till I discovered that the issue was you have to click the Screen Options on the top left of the Dashboard and DISABLE accessibility settings so it looks like the picture below. After that it works fine. I don’t remember setting it so I’m not sure why it got selected.

    DISABLE accessibility settings

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Unable to add widgets’ is closed to new replies.