Support » Plugin: Wordfence Security - Firewall & Malware Scan » Unable to add site

  • Resolved Ken of Kentropolis

    (@ken-of-kentropolis)


    Error: Unable to communicate with Wordfence plugin. Please verify Wordfence is installed and activated on this site.
    Running most recent version of WordPress and Wordfence (activated and running)
    LAMP environment with PHP 7.0
    Not using Cloudflare or other CDN
    No other CMS-based security software running
    MANY other sites on same server and shared IP connect with Wordfence Central fine
    Tried adding from both the site itself and Wordfence Central
    Tried deleting and reinstalling plugin
    Tried adding with http and https
    Tried adding WFAD.ajax(‘wordfence_wfcentral_disconnect’, {}, function() {}); to console
    DIAGNOSTIC EMAIL SENT

    Note: This was reported by other users in other server environments, i.e. https://wordpress.org/support/topic/unable-to-communicate-website-wordfence-central/

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter Ken of Kentropolis

    (@ken-of-kentropolis)

    Correction … PHP version is 7.3.33

    Plugin Support wfphil

    (@wfphil)

    Hi @ken-of-kentropolis

    Load the WordPress REST API endpoint URL for Wordfence below in Firefox:

    https://considerreconsider.com/wp-json/wordfence/v1

    You will see this error:

    SyntaxError: JSON.parse: unexpected non-whitespace character after JSON data at line 1 column 2450 of the JSON data

    Load the WordPress REST API endpoint URL for Wordfence below in Chrome and you will see JSON output:

    https://considerreconsider.com/wp-json/wordfence/v1

    However, the unwanted character error in Firefox is due to this HTML comment at the end of the output:

    <!-- WP Super Cache is installed but broken. The constant WPCACHEHOME must be set in the file wp-config.php and point at the WP Super Cache plugin directory. -->

    If you fix your WP Super Cache plugin installation then the connection should work.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Unable to add site’ is closed to new replies.