Support » Fixing WordPress » Unable To Add/Remove/Edit Menu Items

  • Resolved saeedhurzuk

    (@saeedhurzuk)


    Hi,

    I have been experiencing issues when trying to add anything to the wordpress Primary or any other menu. The error occurs in all states Add/Edit/Remove, It will execute the task the moment i hit save menu, the page then reloads and undoes all changes.

    The Menu was working before i updated Jetpack and WooCommerce a couple of days ago and did a move from MySQL 5.7 to 8.0.

    For debugging i disabled all plugins then tried to add to the menu — Failed
    Then i set it to the default 2021 template while all plugins are still disabled — Failed.

    Although i did notice if i spam add a page to the secondary menu and spam the save it works 1/5 times.

    The error occurs on the first state in which you add the page to the menu. It will show a loading circle and do nothing. The moment you hit the button again it executes and adds to the menu. Although when you hit save menu it then reloads and undos all changes.

    This started a couple of days ago and i’m running out of debug ideas as there is nothing being written to log

Viewing 5 replies - 1 through 5 (of 5 total)
  • Cereno Deng

    (@hiyottaunits)

    Hi @saeedhurzuk – Have you checked the Apache error log? If you don’t know where it is, you can see this page. https://blog.codeasite.com/how-do-i-find-apache-http-server-log-files

    It seams some issues prohibit database writing to make you can’t save menu states.

    Thread Starter saeedhurzuk

    (@saeedhurzuk)

    That was the issue @hiyottaunits there was no errors at all in the apache2 nor wordpress log.

    What i did remember was Bit defender on my Windows Machine had an update and it was installed a couple of days ago.

    What fixed the issue was disabling my anti virus.

    As a full stack web dev, nothing it the log files were way to suspicious.

    Thanks for your reply đŸ™‚

    Cereno Deng

    (@hiyottaunits)

    Hi @saeedhurzuk – Have you try to see the response message in the developer console when you saving your menus?

    Thread Starter saeedhurzuk

    (@saeedhurzuk)

    Hi @hiyottaunits, Yes at the time i started off with the browser console.. Although on my home network it typically renders the console useless unless i know what im looking for.

    I have a custom Private DNS running which blocks ads, stats etc. So the console would typically display a few errors due to not being able to load stats.wp.com, pixel.wp.com and a few other WordPress log and stats domains. At home i’m forced to read and look through the log files directly.

    Cereno Deng

    (@hiyottaunits)

    Hi @saeedhurzuk – Actually I mean to check the response of admin-ajax.php on [Network] tab of Developer tool when select a page and click [Add to Menu] on that [Menus] page (/wp-admin/nav-menus.php). It’s status should be 200 and time is usually less than 1 second.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.