Support » Plugin: OSM - OpenStreetMap » Unable to add html in popup marker content

  • tprod

    (@tprod)


    Hi,

    I’m using your fantastic plugin with OSM. Unfortunately when I add a marker I do not have the ability to add new lines in the marker text.

    Here is the content :

    Address<br>
    Zip - Town<br>

    And it displays like this :

    AddressZip-Town

    Is there a fix you can do for this ? My work is ready for production 😉

    Regards

    • This topic was modified 4 months ago by tprod.
    • This topic was modified 4 months ago by tprod.
    • This topic was modified 4 months ago by tprod.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter tprod

    (@tprod)

    Anyone ?

    Plugin Author MiKa

    (@photoweblog)

    Hello @tprod

    thanks for your feedback! Looks like you found an issue. We could reproduce it and for any reasons it was not covered with the tests … we will have a look to it to provide a version with a fix.
    Meanwhile you can fix it by yourself for the productive page …

    Go to the page/post with the map at the backend – you will find a customfield called:
    OSM_Marker_01_Text
    and the value will be:
    AddressZip-Town
    Change it manually to:
    Address<br>Zip-Town
    Let me know if you face difficulties.

    Br, Michael

    Thread Starter tprod

    (@tprod)

    Hi Mika,

    Thanks for the tip, unfortunately even if I activate custom fields in preferences page, custom fields meta box does not display. I’m stuck cause I don’t have access to the database. Do you know when you’re going to prepare a fix for this ?

    Thanks again for your answer and awesome support 😉

    Regards

    Plugin Author MiKa

    (@photoweblog)

    Hello @tprod

    If you see the text in the marker, then it is stored in the costumfield of this post or page – there is no other location to sore this data.

    You do not enable meta box fields in any preferences page but directly at the post/page – in the right sidebar click options and enable Customfiles. Or “screen options” if you use classic editor.

    Br, Michael

    Thread Starter tprod

    (@tprod)

    Hi,

    Just to tell that your fix works 😉
    Do you plan an other release with a fix for this problem ?
    When can you do it ?

    Thanks

    Cyril

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.