Support » Networking WordPress » Unable to add new users

  • Hi everyone, I have to add a “Store Manager” user to my main site, but when I try to do it I get the following errors:

    Notice: Trying to get property ‘roles’ of non-object in / home / mbeshopp / public_html / wp-content / plugins / wpml-translation-management / classes / user / class-wpml-all-admins-to-translation-managers .php on line 40

    Warning: in_array () expects parameter 2 to be array, null given in / home / mbeshopp / public_html / wp-content / plugins / wpml-translation-management / classes / user / class-wpml-all-admins-to-translation- managers.php on line 40

    Notice: Trying to get property ‘user_login’ of non-object in /home/mbeshopp/public_html/wp-includes/ms-functions.php on line 1483

    Notice: Trying to get property ‘user_login’ of non-object in /home/mbeshopp/public_html/wp-includes/ms-functions.php on line 1500

    What can I do to solve the problem?

Viewing 15 replies - 1 through 15 (of 22 total)
  • Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    First, disable WPML and see if the problem goes away. If so, I recommend asking at https://wpml.org/forums/forum/english-support/#new-post so the plugin’s developers and support community can help you with this.

    Thread Starter igianni84

    (@igianni84)

    I disabled WPML but the problem persists. Screenshot -> https://imgur.com/a/dP5j59T

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    Well, so much for an easy answer.

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for JUST you, while you’re still logged in, without affecting normal visitors to your site. You can then use its admin bar menu to turn on/off plugins and themes one at a time. See https://make.wordpress.org/support/handbook/appendix/troubleshooting-using-the-health-check/ or https://rankmath.com/kb/check-plugin-conflicts/ for more information.

    Thread Starter igianni84

    (@igianni84)

    I have disabled all plugins and enabled the default theme, but the problem persists. Screenshot -> https://imgur.com/a/H0MSiCA

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    I’m not exactly sure what I’m supposed to see in that screenshot.

    Thread Starter igianni84

    (@igianni84)

    I disabled all plugins 🙂

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    Please enable debugging.

    Enable wp_debug and wp_debug_log and after an error, look at wp-content/debug.log to see if anything gets logged there. https://wordpress.org/support/article/debugging-in-wordpress/

    Thread Starter igianni84

    (@igianni84)

    Thanks! I see “[16-Apr-2020 15:42:20 UTC] WordPress errore sul database ALTER command denied to user ‘mbeshopp_wp385’@’localhost’ for table ‘wp_icl_string_translations’ per la query “… so I think that there are some problem with user db permission… 🙂

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    Yeah, I’d start there. Good catch.

    Thread Starter igianni84

    (@igianni84)

    Hi @sterndata I have fix the db problem, but I have a new error that still doesn’t allow me to add new users. Here’s what the log says:

    [21-Apr-2020 08:58:41 UTC] WordPress errore sul database Unknown column ‘spam’ in ‘field list’ per la query INSERT INTO wp_users (user_pass, user_nicename, user_email, user_url, user_registered, user_activation_key, display_name, user_login, spam) VALUES (‘$P$B.xxxxxxx’, ‘siriuxs’, ‘xxxxxxx’, ”, ‘2020-04-21 08:58:41’, ”, ‘siriuxs’, ‘siriuxs’, 0) fatta da wpmu_activate_signup, wpmu_create_user, wp_create_user, wp_insert_user
    [21-Apr-2020 08:58:41 UTC] WordPress errore sul database Unknown column ‘spam’ in ‘where clause’ per la query SELECT COUNT(ID) as c FROM wp_users WHERE spam = ‘0’ AND deleted = ‘0’ fatta da wpmu_activate_signup, wpmu_create_user, wp_create_user, wp_insert_user, do_action(‘user_register’), WP_Hook->do_action, WP_Hook->apply_filters, wp_maybe_update_network_user_counts, wp_update_network_user_counts
    [21-Apr-2020 08:58:41 UTC] PHP Notice: Trying to get property ‘user_login’ of non-object in /home/mbeshopp/public_html/wp-includes/ms-functions.php on line 1483
    [21-Apr-2020 08:58:41 UTC] PHP Notice: Trying to get property ‘user_login’ of non-object in /home/mbeshopp/public_html/wp-includes/ms-functions.php on line 1500
    [21-Apr-2020 08:58:41 UTC] WordPress errore sul database Unknown column ‘spam’ in ‘where clause’ per la query SELECT COUNT(ID) as c FROM wp_users WHERE spam = ‘0’ AND deleted = ‘0’ fatta da wpmu_activate_signup, wpmu_create_user, do_action(‘wpmu_new_user’), WP_Hook->do_action, WP_Hook->apply_filters, wp_maybe_update_network_user_counts, wp_update_network_user_counts

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    “spam” is not a column in the wp_users table. Maybe it was added by a plugin?

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for JUST you, while you’re still logged in, without affecting normal visitors to your site. You can then use its admin bar menu to turn on/off plugins and themes one at a time. See https://make.wordpress.org/support/handbook/appendix/troubleshooting-using-the-health-check/ or https://rankmath.com/kb/check-plugin-conflicts/ for more information.

    Thread Starter igianni84

    (@igianni84)

    It’s very strange … I disabled all the plugins and I set the default theme … but the problem is the same 🙁

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    OK, “spam” is a column when your site is a multisite. Is this currently a multisite installation?

    Thread Starter igianni84

    (@igianni84)

    Sure 🙂

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Actually “spam” is indeed a column in the users table, if you’re running WordPress multisite.

    Are you running multisite? Are you trying to use multisite code on a non-multisite system?

    If so, then the question you want to ask is why is your users table missing columns?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Unable to add new users’ is closed to new replies.