Unable to add new site: "missing email address" (10 posts)

  1. bobri
    Posted 3 years ago #

    Hey all, I have just installed a WordPress network (path-based), but it won't let me add any sites. Under Network Admin->Sites->Add New, I enter a 'Site Address', a 'Site Title' and an 'Admin Email' (the same as for the main site), and hits "Add Site".
    The respons is "Missing email address". And that's it, no site created.
    Any ideas what's wrong?

  2. Have you turned off all your plugins?

  3. bobri
    Posted 3 years ago #

    Thank you for your response!

    There are no active plugins (or even installed ones).

  4. bobri
    Posted 3 years ago #

    Strange...I have looked into the php code (/wp-admin/network/site-new.php) and to me it seems the only reason for this error message is an empty 'email' input field.
    I can write whatever in the field, and always get a "Missing email address" error message, not even an "Invalid email address" when the input is gibberish...

  5. What theme are you using?

  6. bobri
    Posted 3 years ago #

    Twenty Eleven (says my Dashboard page...)

  7. That is ... weird. You're putting in a valid email, right?

  8. bobri
    Posted 3 years ago #

    Yes...and I have tried invalid emails. I've also tried different browsers, but that input field is empty! That is, the response is always "Missing email address".
    Hmmm...The title field is also empty... (I've just used an echo-statement in the php-file). The site-address field keep its value.

  9. Try reuploading the WP files. There may be a corrupt file.

  10. bobri
    Posted 3 years ago #

    I have reinstalled 'everything' from scratch. The problem persists.

    But I have, I hope, found a way to add new sites. Instead of using My Sites -> Network Admin -> Sites -> Add New link, it is possible to use My Sites (in the left menu) and then the Create a New Site link.Seems to work just fine. But I'm not sure whether these are identical or not?
    And somewhere something is still wrong...

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.