Support » Fixing WordPress » Unable to add categories with any contact plugin active

  • I have a pretty fresh installation of WP running and I keep having the weirdest issue. Whenever I have any contact form plugin active (like Contact Form 7, and Easy Contact Forms), I can’t add post categories or any category for some of my other plugins (Woocommerce, Maplist Pro, PrivateContent, etc).

    As soon as I disable the contact plugin everything works again. I’m totally stumped as to what can be causing this issue. At first I thought it was a problem in Contact Form 7 only so I tried another plugin and it did the same thing.

    I spent hours looking for the culprit and figured it had to be a plugin, but never thought this would be it.

    The only other thing that may be relevant is on Friday I was trying a few different caching plugins, but all of them caused other issues so I disabled and removed them. No idea if that’s relevant or not.

    I have a local copy of the site running with pretty much an exact copy of the DB and files (except I had to do a find/replace on the DB SQL file before importing it so it would have my local domain in it). With the local copy I have no issues whatsoever. Again, I’m pretty stumped as to what can be causing this.


    Thanks in advance.

Viewing 11 replies - 1 through 11 (of 11 total)
  • FYI – I just deleted all the WP files and reuploaded them. Same problem. 🙁

    And some more information. It did seem another plugin was causing some issues so I removed that and I’ve gotten a bit further.

    Now, whenever I add a category it seems like nothing is happening. I hit refresh and the category appears. This is even more bizarre. 🙁

    I hit refresh and the category appears. This is even more bizarre. 🙁

    That sounds like caching – either on your site, server or browser??

    I was thinking the same thing, but at this point I don’t have any 3rd party caching plugins installed and I’ve cleared local cache so many times I couldn’t tell you how many!

    Unfortunately I have no idea what kind of caching my host might be using, so I may need to contact them.

    However if the above oddness wasn’t enough to make you scratch your head, I found yet another issue and ONLY when CF7 (or other contact form manager) is active: It also prevents the media manager pop-up window from displaying ANY images!! As soon as I disable it, no problems there either.

    This is getting more and more bizarre and I’m certainly running out of things to try – other than dumping my DB and starting from scratch. But since it’s a live site, this would be bad news.

    I dunno. I don’t recall any issues prior to trying some caching plugins. It wasn’t until today that I needed to do more work so I didn’t see anything odd. I would have assumed after removing those plugins, along with their entries in either htaccess or wp-config, that that would be the end of them.

    Color me stumped.

    I’ve narrowed it down further, I think, but I have no idea if it’s a theme issue or CF7 issue or WP 3.5.1 issue or what. I installed the “fast secure contact form” and I no longer have any issues with adding categories. Unfortunately I still have problems with the media manager when it’s active.

    I just don’t get it. What the heck is so special about “contact forms” that are messing up WP??? I’m seriously considering dumping the DB and selectively importing tables.

    But, even that might not do it. Why? Because I’ve exported the live DB, brought it down to my local install, did a find replace to set the domain properly, and imported it locally. So this being said, if it was a DB issue then I’d have the same problem locally! But I don’t!

    As soon as I think I’m getting somewhere, I end up nowhere…

    It might be a javascript issue – have you checked for those?

    I turned on script debugging and I get 2 warnings when I try to add a category with CF7 active:

    1362502222017 Sync.Engine.Forms WARN GUID query returned undefined; turn on Trace logging for details.
    1362502222017 Sync.Tracker.Forms WARN Attempted to add undefined ID to tracker

    Absolutely NO idea what that means

    Okie dokie… As an attempt to see if I could narrow this down, I setup a temporary site that mirrors the live site. I installed WP fresh and installed all the plugins and theme. Then I tested adding a cat with everything active – no problems.

    Then I took a fresh DB dump, changed the URL’s in it with find/replace, and imported. Problem occurred immediately – couldn’t add a cat.

    I dumped the DB and started with a fresh one. Testing with it after the structure was back. No problems.

    Next I exported each individual table separately, changed URLs as needed and then imported them one at a time until the problem occurs. It started after importing the wp_options table.

    So I think I’ve narrowed it down, but now what? How do I find/fix the issue?

    I’ve tried every DB repair tool I can find and nothing seems to make a difference.


    Well, I’ve done more digging and it isn’t anything in the DB. It has something to do with the theme I’m using, the combination of plugins, and my host. I say my host because I have an exact replica of the site running locally with no issues at all.

    If I enable the default theme the problem goes away.

    I have no idea how to troubleshoot my host for possible issues. Weird.

    This is going from bad to worse. Since I have this on a temp domain I went ahead and turned on wp debug and script debug. With my theme (Shopsum by WP Titans) active and trying to add a category, I get this thrown back:

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 71 bytes) in /hsphere/local/home/acurcion/ on line 149

    I switch to the default theme leaving all the plugins active and I get no errors. What the heck is going on??

    I added in a memory limit line to my config and now everything works. What a pain that was to find!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Unable to add categories with any contact plugin active’ is closed to new replies.