Support » Plugin: WooCommerce » Unable to Activate WooCommerce

  • Resolved Divan

    (@divan-web-devine)


    Hi there,

    WooCommerce worked perfectly, up until this morning, when we received an automatic email from WordPress, indicating that the website is experiencing a technical issue.

    When we attempt to activate WordPress, we receive the following error message (the website is running on PHP 7.3):
    Error: Current PHP version (5.6.40) does not meet minimum requirements for WooCommerce. The plugin requires PHP 7.0.

    We have disabled all other plugins, switched to the default theme, made some changes to the PHP INI Editor, etc. which didn’t solve the issue.

    Do you perhaps have any other suggestions, as the host indicated that everything seems fine on their end?

    Thank you in advance for your feedback.

    Best regards,
    Divan

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Stuart Duff

    (@stuartduff)

    Automattic Happiness Engineer

    Hi @divan-web-devine,

    This seems to be related to your web server as testing with PHP v7.3 I was able to activate the free WooCommerce plugin on several test sites which I created.

    Image Link: https://cloudup.com/czWDscdtKBE

    If PHP v7.3 is correctly installed and configured on your web server WooCommerce would detect that and not identify your current PHP version as being v5.6.40.

    Plugin Support RK

    (@riaanknoetze)

    Hi there,

    Just to check: Is your server indeed running PHP7? I’m asking as this would need to be a server-side configuration and isn’t something WooCommerce would have any direct control over.

    Can you share a copy of your status report as found under **WooCommerce > Status**?

    Thread Starter Divan

    (@divan-web-devine)

    Hi @riaanknoetze / @stuartduff,

    Thank you for your feedback, it’s much appreciated.

    Kindly refer to the two screen shots, located at https://ibb.co/L8gbhxN and https://ibb.co/P62pcQz.

    As you will notice, the PHP version is set to 7.3, as it has been for the past month or so. Even after we change the PHP version to 7.2, 7.4 or 8.0, the same error message (second screen shot) appears when attempting to activate WooCommerce.

    Currently, we cannot even active WooCommerce in order to view the status, as the pesky error message keeps on appearing.

    Thread Starter Divan

    (@divan-web-devine)

    Hi @riaanknoetze / @stuartduff,

    It seems like the hosting company managed to solve this one.

    They didn’t indicate what exactly the issue was though.

    Thank you once again and all the best.

    Plugin Support Stuart Duff

    (@stuartduff)

    Automattic Happiness Engineer

    Hey @divan-web-devine,

    That’s fantastic to hear you have this resolved now 🙂

    Hey suggested clearing the issue by clicking the resolve button in the FaceBook events manager.

    I’m going to mark this forum topic as resolved – if you have any further questions, you can reopen it again if you need be.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.