Support » Plugin: Custom PHP Settings » Unable to access the site after editing max file size setting

  • Resolved srajkrish

    (@srajkrish)


    Please help. I updated the upload_max_filesize in general tab and after the site is not accessible, getting the following error.

    Forbidden

    You don’t have permission to access this resource.Server unable to read htaccess file, denying access to be safe

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author cyclonecode

    (@cyclonecode)

    This seems very strange? What hosting provider are you using? Can you give me a link to the site? If you have (s)ftp/ssh access to the server you should be able to change the permission of the .htaccess file manually. Try the following solutions and see if it solves the problem:

    // Try setting permission to read-write for owner
    chmod 0644 .htaccess
    // Or also setting the execute permission (only used by some servers)
    chmod 0755 .htaccess

    This above could also be done using a FTP client, for instance FileZilla, right click on the .htaccess file and choose “File permission” and enter 644 or 755 in the text box and click save, then try to access you site again.

    I can try to fix this issue for you, but then you must give me access to the server in question so I can see if I can successfully revert to permission. If this seems fine, please email me the credentials on cyclonecode@gmail.com

    Thread Starter srajkrish

    (@srajkrish)

    Thanks for the response. Changing the permission for .htaccess seem to have worked. i.e., site is back up now. But, how do I change the upload_max_filesize using your plugin?

    Plugin Author cyclonecode

    (@cyclonecode)

    What permission did you set and what hosting provider are you using? You should be able to just set the upload_max_filesize from the configuration page, but it seems like something in your environment forces the permission to be 0755 while in most cases 644 should be enough. I need to know more about your environment to be able to make a small patch for the plugin to support this.
    Please give me as much information as possible, for instance:

    1. What file permission did you set to make the site accessible again?
    2. What hosting provider are you using.
    3. Do you know what web server you are running?
    4. What WordPress version are you running?
    5. What version of custom-php-settings are you using?
    6. Can you give me the URL to your site?

    Since the plugin does not seem to work for you right now, you could try to add the php_value upload_max_filesize 256M (or what limit you would like to set) directly into you .htaccess file and see if this works.

    Regards, Krister

    Thread Starter srajkrish

    (@srajkrish)

    I ended up editing php.ini file directly. That solution worked perfectly. Thanks for the prompt responses. I appreciated it.

    Plugin Author cyclonecode

    (@cyclonecode)

    @srajkrish Glad you solved it, but I would really appreciate if you could answer my questions above since it perhaps could help me improve the plugin and stop this from happen to other users in the future. It would be so awesome if I could setup an environment were I could actually reproduce this error so I can fix it in the next release.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Unable to access the site after editing max file size setting’ is closed to new replies.