Support » Plugin: WP Online Store » Unable to Access Admin Section

  • I have just been transferring my website to a new server and followed the guidelines to update the wp-config files. The site and the store are functioning correctly, except that I cannot access the admin section to the store.

    The store is located at:

    When I click on the WP Online store button in the admin section I receive the following errors:

    I have to assume that the wp-config files are not quite right, but I have not been able to figure it out after many hours of trial and error.

    I would be most grateful if anyone can help me with this.

    Warning: require(home/fabinb5/public_html/wp-content/plugins/wp-online-store/admin/includes/classes/logger.php) [function.require]: failed to open stream: No such file or directory in /home/fabinb5/public_html/wp-content/plugins/wp-online-store/admin/includes/application_top.php on line 91

    Warning: require(home/fabinb5/public_html/wp-content/plugins/wp-online-store/admin/includes/classes/logger.php) [function.require]: failed to open stream: No such file or directory in /home/fabinb5/public_html/wp-content/plugins/wp-online-store/admin/includes/application_top.php on line 91

    Fatal error: require() [function.require]: Failed opening required ‘home/fabinb5/public_html/wp-content/plugins/wp-online-store/admin/includes/classes/logger.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/fabinb5/public_html/wp-content/plugins/wp-online-store/admin/includes/application_top.php on line 91

Viewing 5 replies - 1 through 5 (of 5 total)
  • When you changed the details within your configuration files, did you also update the absolute path (that’s the /home/fabinb5/public_html/part) and verified some of the other lines for changes.

    Then, if they are correct, see if the path to logger.php is correct, ie, can the file be found where it is looking?

    I think logger.php is not a critical component and is just used to record the parse time which is set in Admin > Advanced > Logging. You may be able to put // in front of the line which calls it up in your application_top.php

    Thank you for the reply baldguy

    I have checked and triple-checked the paths and they are correct and the files: logger.php and application_top.php are both in place.

    I tried wrapping line 91 which calls logger in application_top as suggested:

    // initialize the logger class
    // require(DIR_WS_CLASSES . 'logger.php');

    Doing this simply changed the error to line 94

    I copy here the admin configure file, in case you or anyone else can see a problem with it:

      define('HTTP_SERVER', '');
      define('HTTP_CATALOG_SERVER', '');
      define('HTTPS_CATALOG_SERVER', '');
      define('ENABLE_SSL_CATALOG', false);
      define('DIR_FS_DOCUMENT_ROOT', 'home/fabinb5/public_html/wp-content/plugins/wp-
      define('DIR_WS_ADMIN', '');
      define('DIR_FS_ADMIN', 'home/fabinb5/public_html/wp-content/plugins/wp-online-
      define('DIR_WS_CATALOG', '/wp-content/plugins/wp-online-store/');
      define('DIR_FS_CATALOG', 'home/fabinb5/public_html/wp-content/plugins/wp-online-
      define('DIR_WS_IMAGES', 'images/');
      define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
      define('DIR_WS_CATALOG_IMAGES', '/wp-content/plugins/WP-online-store-product-
      define('DIR_WS_INCLUDES', 'includes/');
      define('DIR_WS_BOXES',   'boxes/');
      define('DIR_WS_FUNCTIONS',   'functions/');
      define('DIR_WS_CLASSES',  DIR_FS_ADMIN.DIR_WS_INCLUDES. 'classes/');
      define('DIR_WS_MODULES',   'modules/');
      define('DIR_WS_LANGUAGES',  'languages/');
      define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
      define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . '/includes/languages/');
      define('DIR_FS_CATALOG_IMAGES', 'home/fabinb5/public_html/wp-content/plugins/WP-
      define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . '/includes/modules/');
      define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
      define('DB_SERVER', 'localhost');
      define('DB_SERVER_USERNAME', '******_******');
      define('DB_SERVER_PASSWORD', '*********');
      define('DB_DATABASE', '*****_*******');
      define('USE_PCONNECT', 'false');
      define('STORE_SESSIONS', 'mysql');

    I tried placing / in front of /home where the absolute path is given, since it was not there in my old site, but it made no difference.

    I have not changed the domain name, only the server.

    I have updated file permissions to 777 for the relevant files that I found in the wp-online-store help documentation.

    It’s going to be something silly, but I’m going code-crazy looking for it.


    If you have changed the server then perhaps your absolute path has changed – I think this could be server specific.

    See the Absolute Path section in this article:

    Another guess could be that the new server does not have some of the features needed to run logger….? (a wild guess)

    I did look at the article and install the phpinfo file

    The doc_root entry says ‘no value’ – I don’t know what that means, but I know the document root in cPanel is home/fabinb5/public_html

    I also followed the instructions for file permissions and checked with my host if they had any suggestions. Since they are promoted as being wordpress hosting specialists, my guess is that logger should work.

    I tried deleting line 91 from the application_top file, but it it just changed the error to line 94.

    I thought of reinstalling the wp-online-store plugin, but that would remove all of the stock entries. Not sure I want to go down that root. I suppose I do have the database back-up of products.

    OK – I’m finally back in the admin area.

    I cannot even properly identify the problem. I had to delete and reinstall the store plugin and then restore from the back up.

    After reinstalling, the admin area was still not accessible, so there was a mismatch between the plugin and the setup of the new server, since it was fine on the old server. I am going to assume that there was an errant space or spook in the root path, since I cannot see any difference between the configuration files before and after. I simply typed the absolute url into a text file and pasted it into each line in configuration.

    Unfortunately, some of the demo products were showing, so I had to remove those individually. Also, some of the images were missing or confused, so I have had to go through the entire store and check each page. Thankfully, there are only about thirty products!

    Thank you for your help baldguy. Hopefully, this might give a clue to someone else in the future who experiences a similar problem.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Unable to Access Admin Section’ is closed to new replies.