Support » Installing WordPress » Um, I really don’t have any idea what the problem is…

  • Ok, well, I already had a WordPress Blog, but I wanted to update to the new version. So I did, but then it gave me an error…I didn’t want to lose my posts and comments, so I completely reinstalled wordpress and tried linking it to my old database. It then told me my themes were broken, so instead of using the autoinstaller on my host, I deleted it again and uploaded the official version. Now it says my files aren’t there at all. I had asked for help on my hosts forums, and they helped me all they could, but now I am lost…

    This is the post on those forums…I think it explains it better because it is in parts:

Viewing 3 replies - 1 through 3 (of 3 total)
  • Mark (podz)


    Support Maven

    Hmm…..pathoschild ……pffffft

    The steps basically are these:
    – restore the database
    – upload the new wordpress files BUT DO NOT RUN INSTALL
    – so long as the config file is correct, it will just work.

    How are you uploading to the server ?
    Anyway, what version of WP is the old database ?
    What version of WP are you uploading ?

    I’d try to restore table by table. I think you want to KEEP the new admin/password combo for the site. I had a devil of a time when trying to preserve my Wuh-Wuh database files while upgrading to 1.2. I recall having to break each table down and doing it that way. That way, you only reinstall what you need, which is basically your entries and any comments and trackbacks associated with them.

    If you have access to your old database, EXPORT each table into a separate *.SQL file (I know it’s a big PITA but it’s what I had to do and it did work).

    Then reinstall the new and improved WP. Once it’s up and running with the placeholder entry and comment (from Mr. WordPress), then go back into MySQL/PHPMyAdmin and grab these tables, at the very least: _posts, _comments, _categories.

    And then restore the others, table by table, until you have it back the way you want it.

    NOW one caveat, this worked for a migration from Wuh-Wuh (which is like WP 1.0) to WP 1.2. I don’t know if it will work going from 1.2 to 1.5 but if you break your database down into tables, it shouldn’t be hard to just dump the table if it breaks the site.

    Ok, but I’m new to databases and php and such (which is why I used the autoinstaller in the first place) and I don’t really know how to do any of that…

    I’m uploading by FTP and my old version was 1.2 (I believe)

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Um, I really don’t have any idea what the problem is…’ is closed to new replies.