Support » Fixing WordPress » Ultimate TinyMCE toolbar not showing up

  • jordan@triplethreat.org

    (@jordantriplethreatorg)


    Installed the Ultimate TinyMCE plugin. Once installed, it doesn’t show up in the visual tab. Also, the normal WP writing toolbars and kitchen sink also disappear in the visual view when TinyMCE is activated. (Although the HTML toolbar is still visible)

    Once I deactivate TinyMCE, everything goes back to normal. I figure one of the plugins I have installed creates some kind of incompatibility. I know I can go through one-by-one, deactivating these other plugins and re-activating TinyMCE. To try and save some time, I’m just posting the plugins I do have installed in case there is a known disruption between TinyMCE and one of the plugins I have installed.

    Any help would be great.

    Thanks!

    Here’s the plugins I currently have installed.

    All in one SEO Pack
    Better WP Security
    Coin Slider 4 WP
    Contact Form by ContactMe.com
    Custom Post Templates
    Custom Single Post Templates Manager
    Dynanmic Content Gallery
    Easy Social
    Emma Email Signup
    Facebook Comments
    Fotobook
    Google Analyticator
    Google XML Sitemaps
    Grid Archives
    Page Links To
    PayPal Donations
    Simple Page Ordering
    Ultimate TinyMCE
    W3 Total Cache
    WP Google Fonts
    WP Youtube channel gallery

Viewing 15 replies - 1 through 15 (of 19 total)
  • Josh

    (@josh401)

    My money would be on that “WP Google Fonts”.

    jordan@triplethreat.org

    (@jordantriplethreatorg)

    Thanks for the suggestion, Josh.
    No dice on WP Google Fonts, though.

    Josh

    (@josh401)

    Make sure to also empty that “W3 Total Cache” after you have disabled the WP Google Fonts plugin.

    jordan@triplethreat.org

    (@jordantriplethreatorg)

    Thanks Josh. Yeah, that was the first thing I did when I installed TinyMCE.

    Played around with it a little this AM. I disabled all the functions in TinyMCE except 1. Maybe I had too many functions checked and it couldn’t fit them all in the visual toolbar?

    I didn’t read anything about there being a limit, so maybe this is indicative that there is a limit to 1 row or something? Although on a previous website I managed, there was 2 extra rows.

    hmm….

    Josh

    (@josh401)

    Yeah, I’m not sure if there is a limit of buttons in the row. But I’ve added many before (just to experiment) and they would go way off the right edge of the screen. I think I had about 30 buttons across row 1 (this is not optimal however, just experimenting).

    Again, I’m almost positive it is a plugin conflict. Did the editor buttons display once you disabled all the functions (but one) in the ultimate tinymce?

    jordan@triplethreat.org

    (@jordantriplethreatorg)

    Yes. I only enabled one button (image mapping) and it worked. However, when I had about 20 selected, no dice.

    Maybe there’s a tipping point with certain other plugins? I expected it not to work at all, even if I only selected one button. So one of my other plugins must somehow limit the number of buttons that can be displayed?

    Josh

    (@josh401)

    No, it’s not limiting anything. That doesn’t make a difference. Rather, you have a plugin attempting to modify a button already modified in my plugin.

    Ummm… try enabling all the buttons in row 3 and row 4 of the admin panel, EXCEPT for the shortcodes button. I’ve seen this conflict with different theme before.

    I just installed this plugin and it won’t display for me either no matter what I try. I’m guessing it’s something in my theme that’s not liking it…

    Has anyone found a solution for this yet?

    ~ Aedryan

    If you install the Ultimate Tinymce plugin, and the editor becomes solid white (broken), it means there is a conflict with something else attempting to make the same modification to the editor.

    I would begin by disabling all plugins and seeing if it works. If it does, than you know it’s not your theme. And you can begin enabling plugins (a few at a time) until the editor “breaks” again.

    Using this process, you can isolate the plugin causing the conflict.

    Thanks Josh. I was able to get it working, though. As it turns out I just had the editor in HTML view instead of visual… lol DOH!

    Hi, I am having the same issue…. not a white screen (broken) but html only with no tabs to switch from html to visual view.
    Also I do not have a Fonts (or similar) plugin installed…. any other thoughts?
    Thanks

    Try going to the profile page of the user you log in with. In your admin panel, click profiles, and then choose the profile you are using.

    Make sure the selection for using “Visual Editor” is set correctly.

    Not trying to hijack this thread, but the problem i’m having with this plugin is, 4 of the short code buttons for my theme, 4 of the short code buttons for my WP Socializer plugin and 1 short code button for the PHP Snippets plugin are “stuck” on the first line and there doesn’t seem to be any way to move them to other lines. So, when i’m in visual mode it makes the content area really wide and impossible to use. Any ideas how to fix that?

    ~ Aedryan

    Well, there are only a couple of buttons in the ultimate tinymce settings page which MUST be shown on row 1. These are the “div” buttons, the “insert page break” button, and the “advanced insert/edit link” button.

    I believe these are the only three. So, you could disable those buttons in “miscellaneous features” clearing a little room in row 1.

    As far as the other plugins adding buttons to row 1, there is nothing you can do about that with ultimate tinymce.

    If NONE of the buttons of tinymce are installed in row 1, and you are still “spilling over”, we would need to recode those other plugins adding buttons to the first row of the editor. Or contact those plugin authors, and request they code an option to change which row their buttons appear in the editor.

    Thanks Josh. Yeah, that’s the thing, bro… I have all of the buttons in row 1 deactivated, but the buttons are still spilling over. It really sucks that this has to happen, because I love the Ultimate Tinymce plugin and I would hate to not be able to use it, because of this. How would I go about recoding the other plugins?

    ~ Aedryan

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Ultimate TinyMCE toolbar not showing up’ is closed to new replies.