Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » Ultimate member sending incorrect password reset link in email

  • Resolved Tech Architects

    (@techarchitectsinc)


    Hi there,

    I am using free version of Ultimate member, i have been using it for quite a while. All of my pages are assigned properly with shortcodes, i am finishing up building my website and i was doing a error check to see what areas my website needs fixing.

    The issue that i have right now is with the password reset. After creating an account on the website and if you try to reset your password thorough reset password page, you will receive an email with password reset link but the link is broken. Ultimate member is not sending correct password reset link, and it is not any common error, the link does not have a colon(:) post http. So what i am trying to say here is that any link should be in the form of “http://” in order to work, but the link that user receives in email is not same, it is just “http//”. I would have attached an image but there is no option to do so.

    Long story short, ultimate member is not sending the reset password link properly. I have checked with the email, tried to alter it manually but had no luck. If you go to settings>emails>password reset> then as you click on reset password you can change the link, at this moment the link there is “http://{password_reset_link}. I have tried to add the http:// manually in the php file which is resetpw_email.php but had no luck. I have done the conflict test but i still do not receive a proper password reset url.

    Example of password reset link that user receives in email: http//www.techarchitects.in/?page_id=777&act=reset_password&hash=QfHNeq4U6JPDkza4aTTMkg2sDnEMjtYVZriZu00y&user_id=5

    as you can see this is the kind of link user receives which is not really correct as it does not have a : post http.

    Note that if i manually add colon(:) to the link that i receive in email then it works, i am able to reset the password but i am having to alter the link myself which not every user is going to do. So it would be great if ultimate member staff could look into this issue and check what can be done here.

    My website url: http://www.techarchitects.in
    Login page: http://www.techarchitects.in/?page_id=767
    Password reset page: http://www.techarchitects.in/?page_id=777

    Thank you

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter Tech Architects

    (@techarchitectsinc)

    Hi,

    I would like to update that after re-installing the plugin, the issue was resolved, the mystery however still remains that why the incorrect url was being sent, however i have gotten past it.

    Thank you

    I am using WordPress 4.9.8. I tried to upgrade to ultimate member 2.0.16. Ultimate member also sending incorrect password reset link in email. Any help from Ultimate Member Suppor team? Thanks in advance.

    I’m seeing a similar problem. Emails generated by a user clicking “Reset my password” do not include a link. Instead the email shows this line of text:
    Reset your password

    I am also having this problem.

    It looks like others resolved the issue by re-installing the plugin, but I”m worried if I reinstall the plugin I’ll lose the gazillion settings I made. Anyone know how to re-install the plugin without losing current settings? Is that even possible?

    THanks!

    Found the answer! At least for me. Go to Settings and enable HTML for email. Here’s my video on that : https://www.youtube.com/watch?v=137ga-pTDUE

    In my case, I found this solution. I had changed my website theme. Inside the previous theme, the ultimate member install had created two subfolders and installed 10 php files. The php files apparently include the email templates. I copied the ultimate-member subfolders and files from my previous theme into my new theme. Password reset emails from Ultimate Member now have the correct (password reset) link in the email.

    /public_html/wp-content/themes/’your_theme’/ultimate-member/email

    Thank you @abilityseo. Your solution worked perfectly and was so easy.

    Diane

    Hi,

    I’m having the exact same problem. I’ve tried all the solutions I’ve seen so far:

    – check HTML is enabled for emails
    – update Ultimate Member
    – check the PHP file for the password reset email has been installed in my theme (it hadn’t, so I edited the email template in the plugin and the file then appeared, so I’m assuming I’ve done this)

    Users are still having the same problem. I’m using Version 2.0.43 (free version). Any other suggestions?

    I have similar problem – but with {account_activation_link} in email with activation link.
    I’m reciving email with https// not with https://

    Even if I remove this link in template..and type it again..it’s not working.. I’m going to reinstall plugin.
    I have a suspicion that problem occurs when I copied texts from e-mails to templates (not by typing, but by copy/paste)

    I found the solution – when I edit link in template, in Visual editor, it adds at the begining “http://”, when I get to text view I saw it..and delete this prefix.. after that it works good.

    Reinstalling nad turning on/off “html” didn’t help me

    I was able to fix this on my site by excluding the /password-reset page from the cache. (i.e., asking our hosting service –wpengine– to exclude the page)

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Ultimate member sending incorrect password reset link in email’ is closed to new replies.