Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Ultimate Member – Login – Redirect to Specific URL

  • learningwordpress75

    (@learningwordpress75)


    Hi,
    I’m setting up Ultimate Member.
    The Register works fine.
    The Login however leads, after filling in the fields, to a page with an avatar of the member although i want i to redirect (after login) directly to a specifice page.
    How can i do this ?
    Thanks,
    Martin

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @learningwordpress75,

    You can setup redirect after login in Ultimate member -> Settings -> your user role e.g Member and Login options “Action to be taken after login – Redirect to URL”.

    Regards.

    I tried this but its not working the redirect after login.

    Changed in the User role section, the form and still not working.

    any ideas?

    Hi,

    I face same issue. User does not redirect to specific URL after login.

    Any suggestion will help a lot.

    Thanks

    • This reply was modified 1 year, 6 months ago by pradeepphule.

    i cannot find where to put redirect after login, What Tab in Settings do you find this. I see User page as user, if i change that the page i specify place the user name at the end of the url and the page is 404

    https://tradermembers.com/trader-tools-and-information.html/johndoe/

    i want to change Register redirect url from profile to edit profile please send me a code for this

    In addition to changing the user role, this is what worked for me:

    Go to Ultimate Member > Forms
    Select the Login form
    On the right under Options, select Redirect to URL from dropdown
    Under that, put the URL in the Set Custom Redirect URL field

    Hope this helps someone.

    Hi @ultimatemembersupport,

    What if you have done as per you instructions above and as per the manual but the redirect is still going back to the user profile and not the URL specified in User Roles/Login Options

    marvelcreative

    (@marvelcreative)

    Same here, I have set to redirect upon login and registration (from within the User Role settings), but it has no effect. Sadly this makes the plugin useless to me 🙁

    Same here, also in my case, the normal redirect from the url that is requested is lost, so after login, the request url is not redirected to. the only workaround found: deactivate Ultimate Member!

    Nice features, but losing this basic functionality makes it a no-go.

    It didn’t work for me at first either, but then I saw that after setting the redirect method for the user role, you have to click on “Update Role” on the right side panel! (imho not intuitive at all as I was looking for Save settings at the bottom and not finding it assumed it was auto-saved or something).

    So, the following worked for me:
    In Ultimate member -> Settings -> User roles -> Subscriber (or another role you want to configure). Then in Login options “Action to be taken after login – Redirect to URL” and set it to the URL I specified.
    THEN, click in the right sidepanel on top “Update Role” (big blue button).

    Hi

    I want to change url of view profile i.e user/username/ to member/username. Any Idea how can I do this

    Thanks

    Hi
    I am having the same problem, and in my case, it has previous worked before and kept the old URL, I have changed the URL since but it’s still going back to the old URL that doesn’t work anymore!

    Does the author provide any support on this topic as I too have no joy with login redirect. Have tried both updating user role and also changing settings in login form to a specific URL but both methods just simply redirect to default home page after login. This is really really poor…

    Infinitee

    (@infinitee)

    As well s adding a redirect URL to the login Form you need to add a redirect to the Role…

    https://ultimatemember.com/redirect-users-logging-wordpress/

    /wp-admin/admin.php?page=um_roles&tab=edit&id=member&msg=u

    Login Options:
    Action to be taken after login > Redirect to URL

    Set Custom Redirect URL

    markbrealey

    (@markbrealey)

    Thanks Infinitee, I’ll try that 🙂

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.