• Good day,

    I hope you are well.

    When we switch the website to PHP 8 then the Ultimate Member plugin login form does not display – the Username and the Password input fields are gone – only the 2 buttons are visible. I had a look and the input field code is not visible when I inspect.

    Hope to hear from you.

    Thank

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • @pinki1

    I tried with PHP 8.1.10 and the login page is OK with Chrome.

    Which version of PHP 8?
    Which versions of UM and WP?

    Try to activate PHP error logging and post the debug.log file content here in the Forum.

    https://docs.ultimatemember.com/article/1751-enable-debug-logging

    Thread Starter pinki1

    (@pinki1)

    Hi missveronica,

    Hope you are well,

    Thank you for the reply.

    1. Version is PHP 8.0
    2. UM is Version 2.5.0
    3. WordPress version is 6.0.2

    I will try the PHP error logging – I will let you know what happens.

    Thread Starter pinki1

    (@pinki1)

    [ SNIP! ]

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Please do not post large code or responses like that here, it doesn’t work after ~10 lines or so.

    If you need share that data please use https://gist.github.com/ or https://pastebin.com/ instead and post the link to that paste.

    Thread Starter pinki1

    (@pinki1)

    Hi missveronica,

    Debug is on – please see wetransfer link – there was to much content to be placed in the chat. 🙂

    https://we.tl/t-NA4N4PVrAr

    Thanks

    @pinki1

    Ask your Web hosting support to help you with this PHP 8.0 issue.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @pinki1

    Thanks for contacting our support.

    Are you using this plugin?
    https://wordpress.org/plugins/woo-rfq-for-woocommerce/

    Could you please try disabling it when you switch back to PHP 8.0 and see if the issue still occurs with the Ultimate Member?

    Regards,

    Thread Starter pinki1

    (@pinki1)

    Good day,

    Thanks for your feedback.

    I deactivated the NP Quote Request WooCommerce and switched to PHP 8
    I still get the same issue.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @pinki1

    When you switched back to PHP 8, have you tried resizing the browser window and seeing if the Username and Password fields show up after doing that? Let’s see if this is conflict with the style.

    Thread Starter pinki1

    (@pinki1)

    Good day,

    Thank you for your reply.

    The form is still missing (after doing as suggested)

    The registration form is 100% fine – it is just the login form.

    Thank you.

    Is the problem solved? Because i have the same issue after i changed to PHP 8.1 🙁

    [ultimatemember form_id=625] .. or isnt this shortcode working anymore? Thanks for your help!

    I had to return to PHP 7.4 which now only returns a php warning as both PHP 8 or 8.1 result in this stack trace:

    [04-Jan-2023 13:19:47 America/Toronto] PHP Fatal error: Uncaught TypeError: strstr(): Argument #1 ($haystack) must be of type string, array given in /home/foo/public_html/wp-content/plugins/ultimate-member/includes/core/class-form.php:482
    Stack trace:

    0 /home/foo/public_html/wp-content/plugins/ultimate-member/includes/core/class-form.php(482): strstr()

    1 /home/foo/public_html/wp-includes/class-wp-hook.php(308): um\core\Form->form_init()

    2 /home/foo/public_html/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()

    3 /home/foo/public_html/wp-includes/plugin.php(517): WP_Hook->do_action()

    4 /home/foo/public_html/wp-includes/template-loader.php(13): do_action()

    5 /home/foo/public_html/wp-blog-header.php(19): require_once(‘/home/foo/…’)

    6 /home/foo/public_html/index.php(17): require(‘/home/foo/…’)

    7 {main}

    thrown in /home/foo/public_html/wp-content/plugins/ultimate-member/includes/core/class-form.php on line 482

    Please advise

    -Martin

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Ultimate Member Login form issue on PHP 8’ is closed to new replies.