Support » Plugin: Login with Vipps » Uff da, noe gikk galt. Error: invalid_request

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author iverok

    (@iverok)

    Is “ournewsite.no” the actual domain you are trying to set up as the callback-url? As this domain does not exist, this will not work. It has to be a valid URL with a registered domain.

    The error-message you are getting indicates that Vipps does not accept your return-url. Your permalinks are probably ok.

    Thank you for your reply. “Ournewsite.no” is not the actual domain. We have for sure used our valid URL as the callback-url. We have set the client id and the clien secret correctly, we have set the callback url as https://www.samleverdi.no/wp-vipps-login/continue-from-vipps/
    The redirects url (in setup at Vipps portal) are set to: https://www.samleverdi.no/min-konto-2/
    The webhook are set to: https://www.samleverdi.no/wp-vipps-login/continue-from-vipps/

    rgds,
    Kjetil

    Hi. Any suggestions?

    Plugin Author iverok

    (@iverok)

    The redirect URI (the value you should have in this screen: https://ps.w.org/login-with-vipps/assets/screenshot-2.jpg) should be

    https://www.samleverdi.no/wp-vipps-login/continue-from-vipps/

    (You can configure this a bit, but it should almost certainly not be min-konto-2.)

    There are no Webhooks in the WordPress plugin. The redirect URI is where Vipps sends you after login with credentials, the “continue with vipps” page verifies this and logs you in.

    Hi. This is working, at some point. We changed the redirect url, and the Vipps login started, ok. However, when trying to log in/register, at our register page, the user does not receive an email for conformation after accepted the Vipps adresse, email ie.
    Our site is “under construction”, but the test where done after we disabled the “coming soon” for a short time.
    We can give you access to our site if needed.
    – thanks,

    Plugin Author iverok

    (@iverok)

    If you want to keep your data private, you can contact us at support@wp-hosting.no with reference to this issue.

    The confirmation email is actually sent with the standard WordPress mechanism for user confirmation, so I would check to see if your email settings are correct in general (and the mail-log of your systems and so forth).

    Otherwise I should mention that the entire email confirmation step will soon be made optional since Vipps now verifies email addresses automatically.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Uff da, noe gikk galt. Error: invalid_request’ is closed to new replies.