Support » Plugin: WP fail2ban - Advanced Security Plugin » Ubuntu 18.04 dont log AUTH_LOG

  • Resolved jeronimognlz

    (@jeronimognlz)


    Hi, i have the next problem.
    I add to the wp-config.php define('WP_FAIL2BAN_AUTH_LOG', LOG_AUTH); but dont register any logs in /var/log/auth.log (same for /var/log/syslog). I use ISPCONFIG 3.1 .

    Any ideas ?

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author invisnet

    (@invisnet)

    I don’t have an Ubuntu instance to play with atm, but my guess is that you probably need to use LOG_AUTHPRIV.

    Try (maybe a security flaw)
    $ sudo chmod 0755 /var/log/auth.log

    Thread Starter jeronimognlz

    (@jeronimognlz)

    With persmissions:
    -rwxr-xr-x 1 syslog adm 2607083 Oct 25 09:46 auth.log

    and LOG_AUTHPRIV

    I keep logging this:

    Oct 25 12:52:03 server1 wordpress(www.xxxxxxxxx.com)[7733]: Authentication attempt for unknown user sadasd from xxx.xxx.xxx.xxx

    Thanks!

    Plugin Author invisnet

    (@invisnet)

    Sounds like LOG_AUTHPRIV did the trick.

    Changing the perms on the log file is always bad idea – especially setting the execute bit – you should set that back to 640 asap.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Ubuntu 18.04 dont log AUTH_LOG’ is closed to new replies.