Support » Plugin: Comments - wpDiscuz » uBlock Breaks it

  • Resolved tiotrom

    (@tiotrom)


    Here’s a page example https://www.tromjaro.com/to-do/ with uBlock Origin Firefox Extenssion enabled (used by millions) the wpdiscuz breaks and other elements on the page do, like that slider. It seemed to work up until some days ago, maybe sicne the last update of this plugin. If I disable the wpdiscuz the slider works for example. I disabled caching for the plugin but I can still see “wpdiscuz/assets/third-party/wpdcookiejs/customcookie.js?ver=5.3.4” being there and being blocked by adblock.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support gVectors Support

    (@gvectorssupportmember)

    Hi @tiotrom,

    This is something specific on our website.

    We’ve tested wpDiscuz with enabled uBlock Origin Firefox Extension extension and don’t find such an issue.

    Could you please re-activate the wpDiscuz plugin and let us know?

    You can see that /wpdcookiejs/* has been added to the EasyPrivacy list here:

    https://easylist.to/easylist/easyprivacy.txt

    Any ad blocking extension that uses that list is going to break WPDiscuz.

    I am experiencing this same issue. If I disable Ublock Origin on my browser it works perfectly.
    For my site, it’s restricting the loading of the images for the site and also interaction with the comments too.

    @gvectorssupportmember I did and is still not working…
    @tmwnn ah it makes sense now…

    What is /wpdcookiejs/* and why does wpdiscuz need it?

    @gvectorssupportmember, I understand these words syntacticly: “This is something specific on our website.” But I do not understand what those words mean in this context.

    I have three questions:

    1. Do you understand that the EasyPrivacy list, which is a very popular blocklist used by many ad-blocking browser extensions has specifically blocked any URI that contains the segment /wpdcookiejs/?

    2. Do you understand that you can’t just install uBlock and test that WPDiscuz is working still because if your browser has already cached the blocked .js file(s) from that directory, it will still work for you even though those resources are in fact blocked?

    3. Do you have a plan for either convincing EasyList to take that component off their blocklist, or either renaming or replacing the functionality that WPDiscuz needs from that third party code so that it will work reliably for people who are using ad blockers that make use of the EasyPrivacy list?

    Plugin Support gVectors Support

    (@gvectorssupport)

    The developers are checking the issue. Please wait a bit. We’ll update the topic once we get some news for you.

    Plugin Support gVectors Support

    (@gvectorssupportmember)

    The issue is fixed by our developers.

    Please update the wpDiscuz plugin to the latest version (v. 5.3.5), delete all caches and check again.

    Perfect! It works now. Thank you very much!

    Hello

    I was having the same problem as the the original poster.

    I downloaded the newest update about an hour ago.

    My question is whether the update solved the problem with all the ad blockers?

    Because on my site, the same problem was happening with readers who use Adblock plus, and privacy badger as well as a few other blockers in addition to Ublock.

    I’m just wondering if you solved the conflict with all the adblockers or just the conflict with Ublock?

    Thank you

    @uvagrimey
    I actively use ublock origin and privacy badger but using both on my site again now, after the update, and I am not seeing any problems. Hope this helps!

    The issue is fixed by our developers.

    Please update the wpDiscuz plugin to the latest version (v. 5.3.5), delete all caches and check again.

    Hello,

    Thank you for fixing it, the newer 5.3.5 version has indeed fixed that issue, I tested it on my end on another blog.

    *

    However, may I report an issue?

    My wordpress failed to find there was an update to wpdiscuz. I repeatedly clicked to find updates in the administration updates page, and it still told me that everything was up to date, even though I had wpdiscuz 5.3.1.

    I had to do it manually, by FTP, replacing the current wpdiscuz directory with the one inside the zip archive offered on wordpress.org for the 5.3.5 version.

    No idea why. I would imagine it’s a problem with wordpress itself (I’m a bit of a weird case, stuck with wordpress 4.9.8 because my host isn’t offering yet the more recent php versions support), but, hey, just in case I’m wrong and it’s caused by something within wpdiscuz, I’m taking the time to report it.
    You’re welcome to ignore my report of that issue it’s it’s solely a wordpress issue 🙂

    • This reply was modified 4 days, 5 hours ago by Sabinooo.
Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.