Support » Plugins » UAM unpredictable edit access conflict

  • Hi all,

    I am experiencing unpredictable behaviour from the User Access Manager (UAM). My preferred setup is like this:

    Category named ‘Oranges’
    Read: everybody
    write: admin only

    Category named ‘Apples’
    Read: uam group ‘private’
    write: uam group ‘private’ + admin

    When I create the group ‘private’ and apply that group to the category ‘Apples’ it won’t work. This is logic because now users in the group ‘Private’ indeed have access to the ‘Apples’ but they will also have access to ‘Oranges’ since this category has no group restrictions at all.

    So I created a second group called ‘Admin’ with read access all and write access only group users. I applied that group to ‘Oranges’ so that category should not be editable to other groups. But guess what, it is! In fact the users within the ‘Private’ group have access to all categories.

    I experienced this problem before and after extensive research I decided to recreate the categories and user groups and that did the trick. All worked as expected. Now all of a sudden (230 users registered meanwhile) the same bug appears. When I change the read rights for the ‘admin’ group to ‘only group users’ the editing permissions are back to normal but of course nothing appears on the front side.

    To create custom roles I use role editor but that is not the problem because when I simulate the situation on a demo server it works well. This demo server uses the same versions (latest wp & uam) so I don’t think it could be caused by any updates.

    I’ve been shifting settings in all ways but I can’t get it back to normal..


Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi all,

    A few hours of extra investigating:

    1. Full reset + removal of the db tables + reinstall has no effect
    2. When a user group has read access ‘All’ it appears not only readable to everybody but also editable to everybody, in whatever group or no group at all
    3. When I create a new category and apply a group to that everything works normal
    4. Focussed on the fact that new categories do work i tried all kinds of cache emptying, database cleanups but all without result
    5. recreating all categories is not an option, there are about 40 with many posts assigned to them
    6. Alex, I could really use some help here. On this project I spent many, many hours of tweaking uam, I am running out of time and I have no way back @ this point.

      Anybody else with input would be great of course!


    Hi all,

    Another hour and I have some additional findings:

    1. The ‘New category does work’ theory doesn’t seem to work any more after the reinstall en db cleanup
    2. So, still when I create a group with read access ‘All’ everybody of every group can not only read but also edit posts within it
    3. I completely reset and disabled the User role editor but that has no effect



Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘UAM unpredictable edit access conflict’ is closed to new replies.