WordPress.org

Forums

Pods Auto-Display
Tyson .. I'm getting a fatal error. Need help. (3 posts)

  1. garymgordon
    Member
    Posted 1 year ago #

    Tyson, I'm getting a fatal error when I am using Pods Auto-Display.

    I was using your plugin most of yesterday without any issue.
    I just removed 2 plugins, Custom Post Type UI (http://wordpress.org/plugins/custom-post-type-ui/) and a supplemental plugin from WP All Import that worked with the Advanced Custom Fields plugin (http://wordpress.org/plugins/advanced-custom-fields/) and when I deleted these other plugins, since I'm using PODS and didn't need them any longer, I can't seem to activate Pods Auto-Display without getting the fatal error message. So it won't activate. I uninstalled the plugin (using the delete plugin feature in WP) and then reinstalled it, but I'm still getting the same error. Here's what I'm seeing:

    ===============

    Fatal Error (hide details) (remove)
    The site encountered a problem that it cannot recover from. Please use the following information to try to resolve the problem.

    Error Message

    Fatal Error: The Pods Framework plugin must be active. in /home/mysite/public_html/facultyprofiledev/wp-content/plugins/pods-auto-display/pods-auto-display.php on line 19
    Description

    The Pods Auto-Display plugin code created an error that caused PHP execution to fail.

    Solutions

    Invalid code modifications can cause this problem. If you have made any modifications to the plugin, remove them and try to load the site again.
    It is possible that this plugin's code is out of date and that an upgrade is available. Check with the plugin's author to see if an upgrade is available.
    There may be a conflict with another plugin running on the site. Try upgrading the other plugins on the site. A plugin conflict can be ruled out by deactivating all the other active plugins on the site and checking to see if the error still occurs.
    The Pods Auto-Display plugin may not have been fully uploaded. Uploading the plugin again could fix the issue. Important: If you do this, you will lose any modifications made to the plugin.
    Error Source Details

    Type Plugin
    Name Pods Auto-Display
    Version 0.4.1
    Author Tyson Lloyd Thwaites
    Path /home/mysite/public_html/facultyprofiledev/wp-content/plugins/pods-auto-display
    File pods-auto-display.php
    Other Software Details

    WordPress Version 3.8
    PHP Version 5.4.20
    Full Error Details

    Type Code-Generated Fatal Error via trigger_error() (E_USER_ERROR)
    Message The Pods Framework plugin must be active.
    File /home/mysite/public_html/facultyprofiledev/wp-content/plugins/pods-auto-display/pods-auto-display.php
    Line 19
    Type Description Code running on the site purposefully triggered an error. This typically indicates that some unrecoverable problem happened in the code that could only be properly handled by forcing an error so that the code would no longer run.

    ==============

    Can you help?

    Do you know what could be causing this and how I can fix the issue so I can get back to using Pods Auto-Display?

    Please let me know asap.

    Thanks,
    Gary

    http://wordpress.org/plugins/pods-auto-display/

  2. garymgordon
    Member
    Posted 1 year ago #

    Silly me. The issue occurred when I didn't activate PODS. But it still would be better if it recognized that PODS wasn't installed or activated and displayed some other message, other than a FATAL ERROR. Is that possible?

  3. tysonlt
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Gary,

    Glad it worked out for you. I don't have a lot of time to work on the plugin at the moment, so I probably won't be able to make the changes that you have suggested. I am talking to some other developers to see if they might want to take it over.

    How is the plugin working for you generally? I only made it for myself and would be glad if you are getting some use out of it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Pods Auto-Display
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.