WordPress.org

Support

Support » Themes and Templates » [Resolved] Typograph crash site totally on 2.7

[Resolved] Typograph crash site totally on 2.7

  • After i activate Typograph on new 2.7 WP version, only blank white screen appear.
    In server logs it’s look like:
    [error] PHP Fatal error: Cannot redeclare post_class() (previously declared in /server/path/here/public_html/wp-includes/post-template.php:282) in /server/path/here/public_html/wp-content/themes/typograph/functions.php on line 157

    I will use Jason tip to give “default” theme. Fortunately that’s works for me.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yeah. +1 for me.
    Blank pages all round.
    I deleted the theme from my /themes/ dir. This gave me wp-admin back, then I reinstated my old (or any other) theme and I got the front-end back.

    same here … steer clear of this theme 🙂

    I am aware of the problem and it has been fixed. I was using two custom functions called post_class() and comment_class() in the theme and these two were adopted in WordPress 2.7 so there was a massive conflict between the WordPress functions.php file and the Typograph functions.php file.

    I have uploaded an updated version of the theme that deals with this problem to the theme directory. In the meantime while it’s being approved by the powers at be you can go to my blog and download a fully working WP 2.7 Coltrane version. If you replace the old theme directory with this new one everything will be working perfectly again:

    http://blog.pinkandyellow.com/free-wordpress-themes/typograph/

    Mor10

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Typograph crash site totally on 2.7’ is closed to new replies.