Types with PHP 5.4? (5 posts)

  1. oskarlin
    Posted 1 year ago #

    When I switch from PHP version 5.3.18 to 5.4.8 the Types plugin starts acting weird. No custom post types shows up in the admin bar and I cannot access any of those posts on the site.

    Is there a known problem with PHP 5.4 and Types?


  2. Adriano Ferreira
    Plugin Author

    Posted 1 year ago #

    Dear Oskarlin,

    Usually corrupted data is because of menu_icon property,
    if it's changed manually in DB or replaced using some search&replace script.

    If that is case, you should search for 'wpcf-custom-types' option in wp_options table and find something similar to:


    replace with:


    You should do that for all occurrences.

    Tell me if this helps.

  3. Srdjan
    Plugin Author

    Posted 1 year ago #

    Hi Oskarlin,
    thank you for reporting that, we'll have check with PHP 5.4.

  4. oskarlin
    Posted 1 year ago #

    Adriano, I've looked for "menu_icon" and my table already looks exactly like what I'm supposed to replace it with:


  5. oskarlin
    Posted 1 year ago #

    I have now tried installing a fresh WordPress site on PHP 5.4 and Types plugin on another place and everything works fine. So it doesn't seem to be a problem with Types and 5.4 per se.

    I wonder if it could have something to do with slug names or perhaps charset or encodings? For some old reason the char set is "latin1_swedish_ci" so maybe there's something there? I then tried to change all "weird" letters in wpcf-custom-types option to standard ones but same problems occur.

    Also for you to know, when accessing edit.php?post_type=myposttype on PHP 5.4 WordPress tells me "Invalid Post Type" as if it doesn't exist anymore.

    If I downgrade to 5.3 everything is back to normal.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Types
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic