Support » Plugin: Responsive Sliding Menu » Two New Issues

  • jcomanda

    (@jcomanda)


    Does your plugin support icons?

    I installed a Menu Icons plugin from ThemeIsle. It enhances the Menu editor under Appearances > Menus, giving each menu item a chance to install an icon. I have used a “Home” icon for the Home menu option. I can get it to work when I switch to a “regular” (non-FSE) theme and use the “regular” menu that comes with the theme. However, with your menu either on the non-FSE theme or the FSE theme, only the word shows up.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Lekcie

    (@lekciewp)

    Hi,

    Could you add an icon into your menu then send me your website URL please?
    I’ll check this out

    Best,
    Lekcie

    Thread Starter jcomanda

    (@jcomanda)

    I have two versions of the site: Production (non-FSE Theme) and Staging (FSE Theme)

    Production: https://www.everygoodgift.org/
    Staging: https://www.staging2.everygoodgift.org/

    I am using the Menu Icons plugin from ThemeIsle on both of them to assign a “Home” icon to the Home page link on the Main Menu.

    In Production, I am using the “conventional” menu that comes with the theme (not yours), and you can see the icon.

    In Staging, I am using your menu hooked up to the Main Menu. For what it’s worth, I am using “inherit” for the Test Transform property.

    Plugin Author Lekcie

    (@lekciewp)

    Oh ok I understand.
    For now, this feature is not compatible with our plugin.

    We’ll try to include it in the next release.

    Best,
    Lekcie

    Thread Starter jcomanda

    (@jcomanda)

    OK. I can wait. I look forward to it.

    Thank you for looking into it and for your prompt reply.

    Thread Starter jcomanda

    (@jcomanda)

    The title of this thread is “Two New Issues”. I believe I only mentioned one.

    Here is the second thing, and then I will add a third thing.

    The Second Thing
    If I have a menu option that is identical to the name of the page slug, I get a “#660 (no title)” error. In my case, I have a page where the slug is “Shop”. It also happens to be the text of the Navigation Label, but the plugin doesn’t seem to recognize it. It should accept it.

    I can change the text of the Navigation label or the page slug to something else, and the problem goes away, but I shouldn’t have to do that.

    Another odd thing. If you check the URL below, you will see that I have used the menu twice. In the header block and then again below it. The problem only occurs outside of the header block. I have tried putting the menu above the header block, below the header block, and inside the header block. It only malfunctions outside (above or below).

    https://www.staging2.everygoodgift.org/

    The Third Thing
    The menu is not fully flush left. It’s indented (as you can see by the line that is visible). It would be nice if we could control the size of the indent or remove it altogether.

    • This reply was modified 4 months, 1 week ago by jcomanda.
    • This reply was modified 4 months, 1 week ago by jcomanda.
    • This reply was modified 4 months, 1 week ago by jcomanda.
    Thread Starter jcomanda

    (@jcomanda)

    For now I have given up waiting for a resolution of these issues and have decided to go back to the native Gutenberg Navigation block even though it doesn’t slide out. If you ever resolve these issues, let me know. Sorry.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.