WordPress.org

Forums

WooCommerce Poor Guys Swiss Knife
[resolved] two more options (6 posts)

  1. rosso711
    Member
    Posted 1 year ago #

    Hello

    i would like to suggest 2 more options to be added under shop settings:

    1. Show Details label

    2. Add to Cart Button Label (for products using "Variation swatches and colors"). Currently for this i have to edit the actual page directly:

    wp-content/plugins/woocommerce-variation-swatches-and-photos/templates/single-product/variable.php (Line 43)

    <button type="submit" class="single_add_to_cart_button button alt"><?php echo apply_filters('single_add_to_cart_text', __('Add to cart', 'woocommerce'), $product->product_type); ?></button>

    thanks in advance.

    https://wordpress.org/plugins/woocommerce-poor-guys-swiss-knife/

  2. ulihake
    Member
    Plugin Author

    Posted 1 year ago #

    Hello rosso711.

    Seems that you're still using WooCommerce < 2.1 and one of my last updates may have broken the support for add to cart button labels for installations < 2.1... I will fix this.

    uh

  3. rosso711
    Member
    Posted 1 year ago #

    no i am on woocommerce 2.1.5

  4. ulihake
    Member
    Plugin Author

    Posted 1 year ago #

    The code you expose does not belong to 2.1.5. It's code belonging to a version below 2.1. The 2.1.5 html code inside variable.php reads:

    <button type="submit" class="single_add_to_cart_button button alt"><?php echo $product->single_add_to_cart_text(); ?></button>

    And the path 2.1.5 is:

    wp-content/plugins/woocommerce/templates/single-product/add-to-cart/variable.php

    It seems as if you mix up things from two Woocomerce versions and in these circumstances it's quite impossible for me to help you.

    Regards.
    uh

  5. ulihake
    Member
    Plugin Author

    Posted 1 year ago #

    Update on this: You should check if there's an update from WooThemes available for the Variation Swatches and Colors plugin you bought from WooThemes. Your plugin version uses template code from WooCommerce versions below 2.1 and templates are one of the most affected parts when it comes to changes between 2.0 and 2.1 versions of WooCommerce.

    uh

  6. rosso711
    Member
    Posted 1 year ago #

    ok thanks i will check with them to see

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce Poor Guys Swiss Knife
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.