Support » Plugin: Genesis Featured Widget Amplified » Two issues – custom link and post meta

  • Resolved Douglas McLennan

    (@mclennan)



    Fantastic plugin Nick – it has been a workhorse on my sites all these years. And thanks for doing an update yesterday. But two issues with the update:

    1. the plugin has stopped reading the custom link field, so I can’t direct the title of “read more” to my custom field link.

    2. the post meta field has stopped reading entered content in html and renders everything in text (see right column on www. artsjournal.com in the meta fields).

    Sorry to bother you, but these are big issues for me.

    Thanks

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Nick the Geek

    (@nick_thegeek)

    @mclennan

    Sorry for the really long wait. I’m working on some updates for features and fixes. I can’t replicate this issue though. I’m worried maybe I’m doing things wrong. Can you let me know how you are using this, like screen shots of the settings etc. I’m wondering if maybe a specific combination is throwing it off.

    Nick: Thanks so much for responding! Really appreciate it. Doesn’t look like this form will let me upload screenshots. Is there a way I can show you? I’ve uploaded settings screenshots to my Dropbox. https://www.dropbox.com/s/pr7dmp488oe99t4/artsjournal%20item%20genesis%20plugin%20screenshot.jpeg?dl=0

    Grateful for any help. The settings I had worked for several years until that update. the page is here: http://www.artsjournal.com

    Thanks much

    Realize I had forgotten to close the url tag on the screenshot, but it doesn’t change the result. It seems to be reading whatever’s entered in the post and post meta boxes as visible content rather than metadata.

    Plugin Author Nick the Geek

    (@nick_thegeek)

    @mclennan ok I see the issue. I completely misunderstood what you were trying to do.

    So here is what is happening. The output is being escaped, which is why you see the markup on the screen.

    This is important because it prevents XSS attacks. I’ve actually updated with even more escaping in the latest update but not where it would affect this.

    I can look at using a different method to allow the content to be output safely with limited html support so scripts and other potentially unsafe content can’t be skipped into a field.

    I may do this in a way that it can be set via an option or a function. The reason is the other methods that would allow HtML require additional processing that could slow a site down if there are a lot of instances on a page.

    Ah. So is it possible to get rid of the “” <before> option? That’s what I had used to get rid of the “tagged with” prefix. As you can see with the screen shot, the ” show up rather than the blank it’s meant to be.

    Thanks for this plugin, BTW. It really solved a lot ot things I wanted to do.

    Best,

    Doug

    Plugin Author Nick the Geek

    (@nick_thegeek)

    @mclennan, sorry for the delay, there was a bigger mystery that was causing several people issues after they updated GFWA 0.9 I’ve been trying to solve. It was weird.

    Anyway, I just published a release candidate for 0.9.1 that will solve and issue with activating the plugin in Genesis with certain versions and allows safe HTML in the byline and meta field.

    You can download it here
    https://github.com/NicktheGeek/genesis-featured-widget-amplified/releases/tag/0.9.1

    I’m planning on doing the release tomorrow, likely during my lunch.

    Nick: Thanks so much for this. It totally solved the issue of not reading the html in post meta. One thing still not working however: The custom field for link box is still not directing to the new link. I’ve tried it using the field tag and also a straight html. Any possible fix for that?

    Anyway – thanks for fixing the other. That helps me a lot.

    Doug

    Plugin Author Nick the Geek

    (@nick_thegeek)

    @mclennan I think that may be a usage issue.

    The field is for a custom meta field that is added to the post.

    For example, you might add a value like gfwa-url to that field in the widget, then in the post editor add a custom field with the name gfwa-link and the value as the URL you wish the link to point to like http://example.com.

    Then when that post shows up in that instance of the widget it will link elsewhere.

    This is pretty handy because you can make different widgets link to different locations using different custom fields.

    Nick: I actually did that (and it worked until earlier this year when I first contacted you. But it stopped working at the same time as the other issue. I have a custom field called [source] into which I input a custom url to link directly using the headline and “more” link. But It stopped redirecting there. As a workaround, I have been using the “Page Links To” plugin but it is not ideal. After your fix last week, I unchecked the “Page Links To” field and used the [source] custom field in the Featured plugin, but the featured widget page didn’t pull the redirected url.

    doug

    Plugin Author Nick the Geek

    (@nick_thegeek)

    doug,

    Can I get a screenshot for the current setting and the post meta that should be setup for this. I am unable to replicate so I’m not sure if maybe there is a configuration issue or something I don’t have setup the same as you that would break the usage.

    Nick: Here’s a link to the screenshot for the setting: https://www.dropbox.com/s/wwk8lrxya4syjas/featured%20pot%20screenshot.jpeg?dl=0

    And here’s the field for the post meta:

    https://www.dropbox.com/s/x2s59x2d56i7kbl/post%20meta%20screen.jpeg?dl=0

    doug

    Plugin Author Nick the Geek

    (@nick_thegeek)

    @mclennan can you try that without the square brackets?

    Hey Nick: Sorry for the delay getting back to you. Your fix worked with the headline and w/o the square brackets. Curiously, though, it doesn’t do the same for the “read more” link, which still refers to the original post link. I would have thought both worked the same. But the headline fix is much appreciated. Hope you’re staying warm wherever you are (I’m in Seattle).

    Doug

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Two issues – custom link and post meta’ is closed to new replies.