Support » Plugin: Two-Factor » Two-factor with domain mapping – bug?

  • Resolved bregman90

    (@bregman90)


    I am in a scenario where I continually get a “request for email code” from 2-fac when trying to edit my website.

    I am using the following setup:

    1) a domain #1, mynewelectionswebsite.wpcomstaging.com, hosted and managed on WordPress.com
    2) a domain #2, https://benbregmanselections.com/, hosted on Bluehost
    3) Domain #2 redirects to Domain #1, and on WordPress.com I’ve set Domain #2 as the Primary domain (so that all visitors see benbregmanselections.com in their browser but get content build on the WordPress.com-hosted site)
    4) Domain #1 has 2-fac plugin installed, with the email code setting. (It is also using Jetpack, if that is helpful)

    Now, the unexpected behavior: Every-time I try to edit a page via WordPress.com, I need a new 2-fac code. I visit WordPress.com -> Find a page in the site list -> Tap edit. I am prompted to visit my email for a code each time. (If it is helpful info, the URL i see includes a bit “action=jetpack-sso”)

    This behavior only happens if I try to edit from WordPress.com. For example, if I simply navigate directly to https://benbregmanselections.com/wp-admin/ – I am not prompted for 2-fac. But if I ever try edit via the WordPress.com pagelist, my 2-fac “resets” and I need an email again.

    Any thoughts on this combination of tools? (WordPress.com, Jetpack, Domain redirection, 2-fac.) Is there an additional piece of setup I’m missing or is this setup incompatible?… Or, maybe I need to be asking for insight from WordPress.com.

    • This topic was modified 5 months ago by bregman90.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Kaspars

    (@kasparsd)

    Thanks for reporting the issue!

    Is the website hosted on a WP.com plan that allows custom WP plugins? This sounds like a WP.com platform issue so I would suggest you reach out to their support.

    This appears to be an issue with having both Jetpack SSO and the Two-Factor plugin active at the same time.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.