Support » Plugin: Wordfence Security - Firewall & Malware Scan » Two Factor Authentication doesn’t turn on

  • Resolved CZghost

    (@czghost)


    Hello. I am trying to activate two factor authentication for my personal administrator account on my websites. However, when it seems it has been successfully activated, testing it by logging off and logging back on or even refreshing the page reveals it actually didn’t do anything. I have the 2FA in my Google Authenticator app ready to be used, however my websites refuse to activate 2FA for my account.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support wfphil

    (@wfphil)

    Hi @czghost

    When you said, “testing it by logging off and logging back on” – please provide a very precise and detailed description of what happened. If you were able to login make sure that you haven’t added your IP address to the option Whitelisted IP addresses that bypass all rules in the Advanced Firewall Options on the All Options page.

    When you said, “or even refreshing the page reveals it actually didn’t do anything” – please provide a very precise and detailed description what didn’t do anything?

    Thread Starter CZghost

    (@czghost)

    I certainly know I didn’t whitelist my IP. If it did automatically, I cannot tell, but what I know for sure is that when the page was refreshed (with ot without logoff and logon), it reverted back to two factor auth setup, meaning that the two factor auth wasn’t actually set up.

    Whitelisted IP list is empty, and two factor auth isn’t set up. So tested it out again. I’ve set up my two factor auth, saved recovery codes, activated it using Google Authenticator and the code provided, all seemed well (it showed a confirmation message). Refreshed the page and it is reverted back to 2fa setup, meaning nothing has been activated.

    I guess it is worth noting I have Wordfence Free (no paid subscription), so maybe that thing doesn’t work for free users? But then it doesn’t make sense to let users set it up without any notice.

    Plugin Support wfphil

    (@wfphil)

    Hi @czghost

    Thank you for the update.

    It sounds as though the InnoDB database storage engine may have been disabled on the database server or there is a problem on the database server.

    Who is your hosting provider please as I have seen one other similar case this week.

    Please can you ask your hosting provider to see if this exists in the PHP error logs as this will explain why the 2FA can’t be saved because two of our database tables will be missing. This is only part of the full error log but will explain the cause if this error is present. Note that this log has the default WordPress wp_ database prefix:

    WordPress database error Unknown storage engine ‘InnoDB’ for query CREATE TABLE IF NOT EXISTS ‘wp_wfls_2fa_secrets

    Thread Starter CZghost

    (@czghost)

    Okay, so it seems that there is some issue with database, however I cannot find exactly the one you wrote. I get this instead:

    [23-Apr-2020 23:43:34 UTC] WordPress database error Table
    'czghost.myblog_wfls_settings' doesn't exist for query SELECT 'name', 'value',
    'autoload' FROM 'myblog_wfls_settings' WHERE 'name' = 'allow-xml-rpc'
    made by require('wp-blog-header.php'),
    require_once('wp-load.php'), require_once('wp-config.php'),
    require_once('wp-settings.php'),
    include_once('/plugins/wordfence/wordfence.php'),
    require_once('/plugins/wordfence/lib/wordfenceClass.php'),
    require('/plugins/wordfence/modules/login-security/wordfence-login-security.php'), WordfenceLS\Controller_WordfenceLS->init,
    WordfenceLS\Controller_WordfenceLS->_init_actions, WordfenceLS\Controller_Settings->get_bool, WordfenceLS\Controller_Settings->get, WordfenceLS\Settings\Model_DB->get
    
    • This reply was modified 10 months, 2 weeks ago by CZghost.
    • This reply was modified 10 months, 2 weeks ago by CZghost.
    • This reply was modified 10 months, 2 weeks ago by CZghost.
    Thread Starter CZghost

    (@czghost)

    From original reply (held on moderation, I don’t know if it is visible or not):
    Okay, so it seems that there is some issue with database, however I cannot find exactly the one you wrote. I get this instead:
    [posted log]

    The edits are because of backticks breaking it apart.
    I guess better read there: https://pastebin.com/U6wPDiCM

    • This reply was modified 10 months, 2 weeks ago by CZghost.
    • This reply was modified 10 months, 2 weeks ago by CZghost.
    Plugin Support wfphil

    (@wfphil)

    Hi @czghost

    Thank you for the update.

    The error that I provided would have been created on the day that Wordfence was initially activated. Please ask you hosting provider to investigate whether the InnoDB database storage engine has been disabled on the database server or if there is a problem with the InnoDB database storage engine.

    Also who is your hosting provider please?

    Thread Starter CZghost

    (@czghost)

    My hosting provider is Endora.cz. I guess they’re not using InnoDB, they’re eighter using MariaDB or original MySQL for database server. The database shouldn’t be really the cause, because posts and such things are just fine, no error while saving drafts or publishing posts.

    Plugin Support wfphil

    (@wfphil)

    Hi @czghost

    Thank you for the update.

    It is not a case of whether you are using a MariaDB or MySQL database. The issue is that the InnoDB storage engine appears to be disabled or broken. WordPress is using the MyISAM storage engine for all database tables so that is why that is working normally.

    These two Wordfence database tables below must use the InnoDB storage engine and cannot use the MyISAM storage engine:

    wfls_2fa_secrets
    wfls_settings

    Please ask you hosting provider to investigate whether the InnoDB database storage engine has been disabled on the database server or if there is a problem with the InnoDB database storage engine.

    I can then send Wordfence reset instructions so that you can install Wordfence again and those two database tables will be created, as long as your hosting provider fixes the InnoDB database storage engine problem.

    Thread Starter CZghost

    (@czghost)

    So, as it turns out, my hosting provider does support InnoDB engine, but only for paid subscription. I have free subscription of hosting, so I have only MyISAM available.

    I don’t need the two factor auth right now, so I’ll wait with it until I am able to upgrade. Thanks for help.

    Plugin Support wfphil

    (@wfphil)

    Hi @czghost

    Thank you for the update as that explains the fault.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Two Factor Authentication doesn’t turn on’ is closed to new replies.