• Resolved option75

    (@option75)


    Hello,
    I installed two-factor authentication for the e-mail I am using with WP Forms. So, now I ma not getting any e-mails. I went to the debug section and it says authorization not granted or expired. How do I fix this so that I can get e-mails again. I did not know I was going to mess things up by setting up two factor authentication for my e-mail. Thanks for your help!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Jess Quig

    (@jquigam)

    Hi option75,

    Ok, I’ve shared this issue with our development team so that they can investigate it further.

    In the meantime, could you please try re-confirming the authorization? In case it helps, this should be an orange button under the “Authorize redirect URI” field (from Step 3 of our setup tutorial).

    If you don’t see this button, try doing a hard refresh on the page.

    Then, once you’ve done this, go ahead and try sending another test email.

    When you’ve had a chance to give this a try, could you please let me know how it goes? Thanks! 🙂

    Hello,

    Unfortunately, I had to go through all the steps and I got a successfully linked my site to my gmail account. However, I am getting an error saying that I need to login. I can’t send a test account. I have attached a screenshot of the error. I hope that you can help me with this. The plugin was working properly before. Or should I just uninstall/delete the plugin and reinstall? I prefer not since it is a lot of work to set up the web application in my gmail account. So, can you please look at the error and let me now know how I can fix this? Actually, I cannot attach here but I copied and pasting it here:

    “There was a problem while sending a test email. Related debugging output is shown below:

    Versions:
    WordPress: 4.9.5
    WordPress MS: Yes
    PHP: 5.6.36
    WP Mail SMTP: 1.2.5

    Params:
    Mailer: gmail
    Constants: No
    Client ID/Secret: Yes
    Auth Code: Yes
    Access Token: No

    Server:
    OpenSSL: Yes
    PHP.allow_url_fopen: No
    PHP.stream_socket_client(): Yes
    PHP.fsockopen(): Yes
    PHP.curl_version(): Yes

    Debug:
    Error while sending via Gmail mailer: {
    “error”: {
    “errors”: [
    {
    “domain”: “global”,
    “reason”: “required”,
    “message”: “Login Required”,
    “locationType”: “header”,
    “location”: “Authorization”
    }
    ],
    “code”: 401,
    “message”: “Login Required”
    }
    }

    Thank you,
    Janet

    Plugin Support Jess Quig

    (@jquigam)

    Hi Janet,

    I’m sorry to hear you ran into issues in this setup process!

    The error you’re seeing occurs when Google doesn’t think you’ve provided authorization yet (the orange button in Step 3 of our tutorial).

    Here are the best next steps:

    1) Try going back through the tutorial (repeat all steps and recopy any details). This can be frustrating, however in many cases it will catch something that was missed the first time around.

    2) If you repeat all of the steps and still see this same issue, next you’ll need to reach out to your site’s hosting provider. In some cases the host will have some kind of block in place that prevents this from working properly, and they should be able to investigate this further for you.

    3) Last, if your host is unable to provide the assistance you need, you could consider one of our other recommended SMTP options also.

    I hope this helps! 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Two-Factor Authentication’ is closed to new replies.