Support » Plugin: Google Analytics Post Pageviews » Two errors, and a question

  • Resolved immanence

    (@immanence)


    1. The plugin settings page tells me to put this code in the template:
    <?php echo gapp_get_post_pageviews(); >
    It should be:
    <?php echo gapp_get_post_pageviews(); ?>

    2. On the plugin settings page, I have “None” in the pulldown for “Use this website to retrieve pageviews numbers:” I’m pretty sure I followed your set up instructions to the letter, including the Google API Project setup. On my site, I have 0 page views for posts I know are being viewed.

    3. Question: Will this plugin play well with W3 Total Cache, which I have implemented on my site? I also use Cloudflare.

    Thanks for your time

    http://wordpress.org/extend/plugins/google-analytics-post-pageviews/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Yes, the code should obviously be:
    <?php echo gapp_get_post_pageviews(); ?>

    But then it works fine, also with W3 TC!

    Thank you for this great plugin.
    Angie

    Oops, spoke too soon…

    How to keep the API token alive, that’s the issue now.
    Pageviews show only once and do not update, until the next disconnect-reconnect.

    Any ideas?
    Thanks in advance,
    Angie

    UPDATE:

    We didn’t take the caching into consideration.
    Once the cache is flushed, the new views appear.
    Works fine for us!

    Thanks again,
    Angie

    I have used your plugin and found that
    <?php echo gapp_get_post_pageviews(); ?>

    doesn’t work at all and where I put it in my wordpress theme, page die after that.

    waiting for you positive response.

    I hope you will reply.

    @kjkdfdsfos, you should provide more info when saying something doesn’t work… I just installed the plugin and I am using it with no problem.

    Have you followed the instructions and created a project at google APIs?

    @plugin author – great work mate!
    Are you interested in extending plugin with more options? For example, I will be using your plugin to display page views only for last month. Instead of 'start-date' => $options['gapp_startdate'], on line 342 I used 'start-date' => date("Y-m-d", strtotime("-1 month", strtotime(date('Y-m-d')))),

    This made me thinking, your function gapp_get_post_pageviews() could be extended with lots of options…

    I am experiencing the same problem:

    2. On the plugin settings page, I have “None” in the pulldown for “Use this website to retrieve pageviews numbers:” I’m pretty sure I followed your set up instructions to the letter, including the Google API Project setup. On my site, I have 0 page views for posts I know are being viewed.

    esmi

    (@esmi)

    Forum Moderator

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Two errors, and a question’ is closed to new replies.