WordPress.org

Support

Support » Plugins and Hacks » Woocommerce CSV importer » [Resolved] Two errors and a doubt

[Resolved] Two errors and a doubt

  • Hi there!

    First of all, thanks a lot for your work. The plugin does what I need! 🙂

    When I try to import a file, I’m getting three errors (the first one ocurred in previous imports as well and didn’t prevent the products from importing). Here they are:

    Warning: set_time_limit() has been disabled for security reasons in /home2/bsauctsg/public_html/wp-content/plugins/woocommerce-csvimport/include/woocommerce-csvimport-functions.php on line 91
    
    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home2/bsauctsg/public_html/wp-includes/post.php on line 2996
    
    Fatal error: Cannot use object of type WP_Error as array in /home2/bsauctsg/public_html/wp-content/plugins/woocommerce-csvimport/include/woocommerce-csvimport-functions.php on line 214

    My WP is 3.5, maybe it has something to do with it.

    I’ve also seen in your example file that there are three types of prices: price, regular_price and sales_price. Could you let me know how to enter the data so I only get a regular price, without any offer??

    Thanks a lot in advance

    http://wordpress.org/extend/plugins/woocommerce-csvimport/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author allaerd

    @allaerd

    Hi there,

    The issue is resolved in version 0.7.0.

    About the prices.

    price is always the price.

    If you want sales prices:

    price = sales price
    and regular price > sales price
    so 10, 100, 10

    Plugin Author allaerd

    @allaerd

    the time limit is a setting i have for infinite times. Some hosting providers block this. So please be aware with BIG CSV files

    Hi!

    Thanks for your answer.

    I’ve updated the plugin but I’m still getting the last error:

    Cannot use object of type WP_Error as array in /home2/bsauctsg/public_html/wp-content/plugins/woocommerce-csvimport/include/woocommerce-csvimport-functions.php on line 218

    Thanks a lot in advance! 🙂

    I figured out myself. I changed the field separator and never changed it back.

    Thanks a ton! 🙂

    I’m having the same error pls. What exactly did you do to solve it manuelraigada?

    Hi, I’m getting the same error, I haven’t changed any of the settings and have even tried uploading the sample file but having no joy. Can you shed any light on what you did?

    Plugin Author allaerd

    @allaerd

    In the settings page, you can set the field seperator.

    Which settings page, and what is the field separator for?

    Settings of the plugin. Separator for separate fields on your CSV file. (at most its , or 😉

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Two errors and a doubt’ is closed to new replies.
Skip to toolbar