Support » Plugin: Custom Body Class » Two Bugs in Plugin Associated with Autocomplete and Allow Edit Fields

  • Resolved Michael Samson

    (@illuminice)


    Hello,

    My thanks for this very simple and effective plugin. It was exactly what I was looking for. I compared this with one other similar plugin which was far too overloaded with features. Sometimes less is more! 😉

    I just wanted to let you know I found two bugs in the plugin…

    1. If you disable the Autocomplete feature it causes the meta-box to malfunction in post pages of the admin. The problem manifests itself as the inability to relocate any meta-boxes when editing a page. It also causes other meta-boxes on the page to malfunction. In my case one meta-box with multiple tabs was combining all the tabs together. Basically there was a script error from your plugin causing all of this. When I enabled the autocomplete feature the problem went away.

    2. The feature for allowing/disallowing of editing fields for editors seems to be broken. I assume this feature is meant to only allow administrators to change the entered classes. I found that if I disabled this feature (to prevent access for editors) it actually caused the meta-box to not appear at all, even for administrators. I saw this issue before figuring out the cause of issue #1, so I don’t know if it’s related or not.

    Beyond this everything seems to be working, at least with using the page feature which is all I needed.

    Hope this helps!

    ~ Michael

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Andrei Lupu

    (@euthelup)

    Sorry for this late response, I was a little bit offline lately.

    Thank you for reporting this and I will make sure to fix it next week.

    Thanks again!

    Hi Andrei,

    Better late than never!

    I’m still using your plugin and these issues are still present, so it would be great to see these fixed.

    I’ll keep an eye out for the next plugin update.

    Thanks!

    ~ Michael

    Plugin Author Andrei Lupu

    (@euthelup)

    Hi!

    I just updated the plugin with these fixes.

    Cheers!

    Hi Andrei,

    Thank you for fixing these two issues. I’ll update the plugin shortly and will test the corrections for you. This way you know they are definitely fixed on my end.

    Thanks again for taking care of this!

    ~ Michael

    Hi Andrei,

    I wanted to follow up with you regarding the results of my testing.

    I can confirm that Issue #1 is definitely fixed. I tested by disabling the auto-complete feature, and this time all of the meta boxes functioned properly when editing a page in the admin.

    For Issue #2 it looks like I originally misunderstood what that feature was for. If you disable the editor feature then you cannot add custom body classes in the admin (by design). It simply removes the editor, but pre-exisitng entries are still there on the back-end. Please correct me if I am wrong.

    I found that if you disabled the editor that it would not display even if you’re logged in as an admin (I assume this too is by design).

    It looks like you added a new third setting to restrict editor access to admins only. I don’t recall that being there before. This is the only thing I couldn’t test, because we only use admin/subscriber accounts. So only admins have access to the WP admin. I don’t have an editor account to test with.

    I did however test by disabling the editor feature while simultaneously limiting editor access to only admins. In that situation the editor does not display for admins (which I also assume is by design).

    So it looks like everything is fixed here. Please let me know if any of my above assumptions are incorrect, and thank you again for fixing this!

    All my best,

    ~ Michael

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Two Bugs in Plugin Associated with Autocomplete and Allow Edit Fields’ is closed to new replies.