WordPress.org

Forums

Twitter Widget Pro
Twitter Widget Pro 2.6 won't authorize account (21 posts)

  1. web_man
    Member
    Posted 1 year ago #

    I've searched the forums and none of the topics have helped. The errors I receive are:
    Could not recognize the response from Twitter
    You need to authorize your Twitter accounts.

    Here are the steps I have taken:
    - Created a new app at Twitter (several times)
    - Reset the keys
    - Valid Callback URL
    - Ensured it has read and write access
    - Allow this application to be used to Sign in with Twitter
    - Removed the keys several times in WP
    - Removed the old account info in WP

    The plugin was working fine up until a week ago. I updated to the new version 2.6 and now the feed doesn't work. I'm using WordPress 3.4.2

    This is so frustrating!!! Something was working fine, then stops working. I'm on IIS with PhP 5. I really don't think it's the web server. It's the Twitter plugin!!!

    This is for one of my clients and they need this ASAP. I'll have to look at another plugin if this one no longer works.

    http://wordpress.org/plugins/twitter-widget-pro/

    [Moderator Note: No bumping. If it's that urgent, consider hiring someone.]

  2. kaifanun
    Member
    Posted 1 year ago #

    I'm having the same issue. Weeb_man have you found a solution?

  3. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    I don't have any WordPress installs that old to test on. I strongly suggest that you upgrade to the latest version of WordPress and try again.

    Also, what exact version of PHP are you using? Version 2.6 actually had some fixes to work around a bug in certain versions of PHP (specifically this one: https://bugs.php.net/bug.php?id=45989), but it's possible there are other versions of PHP with similar issues.

  4. web_man
    Member
    Posted 1 year ago #

    I'm using PhP version 5.

    I just need this to work and to update WordPress right now isn't the way to go. Why did the old plugin stop working? Is there any way to use the old plugin like before?

  5. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    PHP 5 is not high enough to meet the WordPress minimum requirements: http://wordpress.org/about/requirements/

    You need at least 5.2.4

    Also, did you update WordPress?

  6. web_man
    Member
    Posted 1 year ago #

    I checked the server and I'm using PhP version 5.3.18.

    Updating WordPress isn't in the cards right now since it isn't a guaranteed fix for the issue. Also comes extra cost with testing the upgrade in a test environment and tracking down the other plugins that need updating as well before putting it live.

  7. internethappens
    Member
    Posted 1 year ago #

    Same issue here. WordPress is updated to latest version. Theme is up to date and compatible. Minimal plugins installed. PHP V 5.3

  8. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    internethappens: Sounds like you are in a better position to test this. Can you disable all other plugins and test?

  9. internethappens
    Member
    Posted 1 year ago #

    I disabled all plugins. Same issue.

    WordPress 3.6.1
    Theme: Souffle (mothemes.com) 2.1
    Twitter Widget Pro 2.6.0

  10. web_man
    Member
    Posted 1 year ago #

    I'm glad I didn't go through the process of upgrading WordPress. Thanks internethappens.

  11. Nshoe
    Member
    Posted 1 year ago #

    I'm having an issue with getting the twitter widget set up. I have my authentication done, but in the Twitter Widget Pro Settings I keep getting the "Could not recognize the response from Twitter". Any tips? Thank you.

  12. retrocool
    Member
    Posted 1 year ago #

    I'm also seeing:
    "You need to authorize your Twitter accounts."
    and when I click the Authorise New Account button, I get:
    "Could not recognize the response from Twitter"

    WordPress 3.6.1 (new install)
    Theme Hybrid
    No other plug-ins active

  13. stevendaily
    Member
    Posted 1 year ago #

    I am also unable to get the authorization process to work. I do not see any error message, but I just keep getting the "You need to authorize your Twitter accounts" message.

    WordPress 3.6.1
    Twitter Widget Pro 2.6.0

  14. info@jtcconsulting.ca
    Member
    Posted 1 year ago #

    Same issue here, has anyone been able to find a solution?

  15. Mike Castro Demaria
    Member
    Posted 1 year ago #

    Same here with 3.7

  16. abdul.mannan
    Member
    Posted 1 year ago #

    Having the same issue :-(

    "You need to authorize your Twitter accounts."
    and when I click the Authorize New Account button, I get the following error.
    "Could not recognize the response from Twitter"

    WordPress 3.4.1
    All other plugins are disabled

  17. jcederholm
    Member
    Posted 1 year ago #

    Same thing here, cannot authorize. Using 3.7.1
    Is this issue being looked into at all?

  18. esmi
    Forum Moderator
    Posted 1 year ago #

    @abdul.mannan & @jcederholm: If you require assistance then, as per the Forum Welcome, please post your own topics.

  19. etaege
    Member
    Posted 1 year ago #

    I am also having the same issue, and this does seem like the most relevant place to post this topic. I'm surprised no one has come up with a solution yet.

    "You need to authorize your Twitter accounts."
    and when I click the Authorize New Account button, I get the following error.
    "Could not recognize the response from Twitter"

    WordPress 3.6.1
    Haven't tried disabling plugins, but I'd like to avoid that if I can.

  20. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Why are you using an old version of WP? Are you aware that that's a major security risk?

  21. etaege
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Twitter Widget Pro
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.