WordPress.org

Support

Support » Plugins and Hacks » Twitter Tools problem with Sidebar Modules

Twitter Tools problem with Sidebar Modules

  • Alex, great job on getting this done so quickly. Looks like there may be issues if using Sidebar Modules as opposed to widgets. I’m using them within K2 and they cause all modules to disappear in the console. The site still operates fine.

Viewing 8 replies - 1 through 8 (of 8 total)
  • If there is an easy fix and someone submits a patch, I’ll take a look.

    I didn’t notice this before commenting on AK’s site but if you change line 567 to

    add_action(’plugins_loaded‘, ‘aktt_widget_init’);

    the plugin will work.

    Hmm, I kinda like hooking in at init – that’s when everything is accessible.

    I changed line 567 to

    add_action(’plugins_loaded‘, ‘aktt_widget_init’);

    but now nothing will show up. Before text would show up and say that no feed/update was available but now there isn’t even any text.

    Any thoughts?

    I tried updating to 1.0b3 but still getting a fatal error in the sidebar. Is it the sidebar modules doing this? Thanks for your help.

    Twitter Tools is not tested with Sidebar Modules, so if it does work it is by happy coincidence.

    This fix worked for me, but note that as of March 24th it is not line 567, but instead line 537 where this line is.

    It does seem to make it work fine with Sidebar Modules (I’m using K2 as well).

    Hey thanks for the help, it’s working fine. I just edited line 537 with the edit above and used a php module with the call <?php aktt_sidebar_tweets(); ?>

    And it’s working.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Twitter Tools problem with Sidebar Modules’ is closed to new replies.