Support » Plugins » Twitter Tools not updating

Viewing 15 replies - 31 through 45 (of 76 total)
  • everyone seems to be having a similar problem, but so far we haven’t found a solution.

    I’m sorry, but I strongly disagree with that statement. There are at least a half-dozen different reports of problems in this thread, nont of which I have been able to reproduce.

    1. Tweets not updating (not being downloaded from Twitter).
    2. Digests not posting as expected.
    3. Unable to log in to Twitter.
    4. Not sending tweets on new blog posts.
    5. “Quit working”
    6. “Mine is working here and there, but certainly not like it used to.”
    7. Issues with URL shortening.

    Along with a variety of reports that it has “started working again” from the same folks who have been reporting the problems. Unless they are hacking on it, the plugin code is the same in both cases (“broken” and “working”).

    I am happy to provide details of when Twitter Tools has worked, and when it hasn’t. What other type of information do you need?

    A good bug report with a reproducible use case looks something like this:

    Twitter Tools Version: x.x
    WordPress Version: x.x
    Expected Behavior: I do X, Y happens
    Observed Behavior: When I do X with the following blog post title “Mary had a little lamb”, Y does not happen. When I do X with the following blog post title “Whose fleece was white as snow”, Y does happen.

    I should then be able to recreate that situation and see the problem as described. Once I can do that, I can debug it and fix.

    The reports here are too general, completely unreproducible in my testing (I’ve wasted hours trying to reproduce some of these issues, only to find that people entered passwords wrong, etc.), and mostly covered by the FAQs I linked to.

    If I seem short on patience about this it is because I am. There are many wonderful folks that use my plugins that I’ve enjoyed corresponding with; people who have provided helpful feedback, suggestions and bug reports. I’ve also seen complaints about “issues” (and by extension, my reputation dragged through the mud) by people that can’t figure out how to correctly enter their username and password, read the included README, make false assumptions and build on them, etc. It can be extremely frustrating, and I simply cannot engage in discussions with all of the folks in the latter group – there are just too many WordPress users out there.

    This is why I founded the WordPress HelpCenter and created the affiliate program to support WordPress developers – individual developers can’t be expected to support millions of WordPress users on their own time and expense.

    I too had the issue of Twitter Tools not posting the daily digest of tweets on my Blog. The way I solved it, is documented at my blog. Please refer to the section Update (November 15, 2009): on this page.

    I have been having a similar problem, and while Twitter Tools is posting my blog post to Twitter, I am not longer receiving the daily blog posts Twitter Digests I so used to like getting. I believe I have the most current versions of everything, though I am still having this issue.

    Following Alex’s suggestion, I will try to provide the bug report he suggested:

    A good bug report with a reproducible use case looks something like this:

    Twitter Tools Version: 2.0
    WordPress Version: 2.8.6
    Expected Behavior: I post to Twitter every day, and I expect a daily digest of my Tweets to post to my blog
    Observed Behavior: The Tweets never post to my blog

    I took a screen shot of the top of Twitter Tools in my blog’s admin screen, and noticed there is a strange look for the date:

    The drop downs also seem a little odd, so I took another screenshot of one of them:

    Any suggestions will be appreciated. This used to work wonderfully, and has long since been one of my favorite plug-ins!

    Hi Alex,

    First let me say I love your plugin and it’s been great. However, I’ve started to have some issues of late. About two weeks ago Twitter started acting wonky and so I blamed Twitter and took a wait and see approach. Everything started working Ok again for about a week, no updates, no changes to the WP or TT.

    Yesterday, I upgraded to TT 2.0, and I noticed that my posts were posting without URLs and I have the api and username setup. I tried upgrading WP, and that hasn’t changed anything. I’m just at a loss as to how to proceed and wanted to share with my fellow users out there.

    Twitter Tools Version: x2.0
    WordPress Version: 2.8.6

    Try to change JS Library to use fro JQuery to prototype. I try this method and now my tweet has been work and updated

    Twitter Tools Version: x2.0
    WordPress Version: 2.8.6

    Despite selecting that I want Twitter notified of my new posts, nothing is being posted on my Twitter account.

    Try to change JS Library to use fro JQuery to prototype.

    Tried this, but it didn’t work.

    I know people are having various problems, but I was wondering if anyone has been having this problem and if they found a solution.


    embarrassed to say but; switching the theme to default, adding sidebar widget, updating tweet options, and tweets. Switched back to my minimal theme; and Twitter Tools Now Updates. Yes!

    Twitter Tools Version: 2.0
    WordPress Version: 2.8.6
    Expected Behavior: I post to Twitter throughout the week with a weekly digest to be published on Saturday at 4PM.
    Observed Behavior: The digest never posts to my blog. I have already used the Reset Digest feature to attempt to resolve this.

    I’ve had this problem for going on a month now and would really like to find a resolution to it.

    I tried shekharg’s solution. It worked — for one daily digest. 🙁

    This is frustrating.

    Been having issues with Twitter tools since upgrading to PHP 5.3. I get the following error:

    [Mon Jan 11 20:42:13 2010] [error] [client] PHP Warning:  fsockopen(): php_network_getaddresses: getaddrinfo failed: System error in /Library/WebServer/Documents/website/wp-includes/class-snoopy.php on line 1142
    [Mon Jan 11 20:42:13 2010] [error] [client] PHP Warning:  fsockopen(): unable to connect to (php_network_getaddresses: getaddrinfo failed: System error) in /Library/WebServer/Documents/website/wp-includes/class-snoopy.php on line 1142

    Anyone else using WP 2.9.1, PHP 5.3, and Twitter Tools 2.1.2? =/


    Well, since this issue has been going on for awhile, and no one can seem to find an answer, I’m giving TT the boot.

    I’ve been using Twitter Digest (supposedly based on Twitter Tools — funny how IT works) in between attempts to fix TT. It suffers from a few hiccups, like occasionally posting the digest multiple times or not at all (the digest would be there, it just missed its scheduled posting time and has to be posted manually), and it means I will have to manually crosspost my blog links to Twitter but since I tweet more than I blog, this is a small price to pay IMHO.

    I’ve also been having issues ever since upgrading TT to 2.1.2 (which I did shortly after upgrading WP to 2.9.1). I’ve tried all the suggested fixes, remove/reinstall TT (dropped the aktt_ rows from the wp_options as well as tried previous versions), deactivate/reactivate Akismet, changed themes. Nothing has worked so far. I mostly get “Sorry, login failed. Error message from Twitter: Rate limit exceeded. Clients may not make more than 150 requests per hour.” when I test my login, but even when it succeeds, TT is not grabbing any tweets since 1/11.

    Just tested Twitter Digest and it works fine. I’ll keep checking on TT as it has a preferred feature that Twitter Digest doesn’t (i.e., non-digest tweet to post).

    I’m experiencing a lack of updates on two different blogs, both running 2.9.1 and TT 2.1.2 on a server with PHP 5.2.4. One had been up and running for several years, with 4,000 items in the wp_ak_twitter table. The other site is brand new, with a clean install of WP and TT.

    Authentication to Twitter works fine – both in the admin settings test and when I publish a blog post. The issue I’m seeing is that when the scheduled pull from Twitter goes out every 10 minutes, it pulls one item, sets the tw_id to 2147483647 (the maximum value for a 32-bit signed integer, aka sign of the Twitpocalypse), then refuses to pull any new tweets after that.

    I’ve tried dumping the aktt settings from the options table, loading and unloading the plugin, etc., but when it happened on the new blog, it made me think it might be something with my installation of MySQL (or I guess PHP). I don’t see any auto_increment fields that could be a factor, though. I’ve also looked through the plugin code, but nothing really jumped out at me…

    I think davidkingsbury is on to something. The tw_id of my last entry is also 2147483647. If I delete that entry, TT will pull down one more, assign it that same ID and stops. My table only has 453 rows.

    My hosts MySQL version is 5.0.83, PHP version is 5.2.2.

    The tw_id is not a number randomly generated by SQL or TT, it is the ID from Twitter which you would see in the url if you directly went to an individual tweet. The post of mine that keeps getting assigned that ID by TT does not use that ID from Twitter.

Viewing 15 replies - 31 through 45 (of 76 total)
  • The topic ‘Twitter Tools not updating’ is closed to new replies.