Support » Plugins » Twitter Tools No Longer Working

  • I was using Twitter Tools 1.1b1 for a long time, I never felt like upgrading until recently when I wanted to add @reply filtering and saw that there was a 1.2b1, so I upgraded to that, and it stopped working entirely. I tried deactivating the plugin, wiping the option parameters in MySQL, etc, etc, but nothing would get it to start capturing Twitters again, nor would it post blog posts to Twitter. (I even looked in the database: it wasn’t capturing Tweets to the internal database, either.)

    I waited two days, and found 1.5b1 and hoped it would be my savior, but there was PHP5 code in it so it really didn’t work, until I enabled PHP5 on my server and… it still didn’t work. It doesn’t, hasn’t, thrown any errors at me (aside from that PHP5 error), and according to the prompts my login works fine. I thought that maybe my Twitter password (16 characters) was too long, so I changed that, but no dice on that either.

    I went ahead, again, and wiped the MySQL option parameters, and even went so far as to delete all 2,800 twitters in the AKTT database, just on the off chance that something was wonky there, and reinstalled it, set it back up, and nothing.

    Until about an hour later when I checked my site and saw that TT double-posted the day worth of Twitters, and I got excited, thinking: sweet! it’s working! poorly, but working! But I removed the double-posts and it hasn’t worked…

    … until a few minutes ago, where it seems to have posted an @reply (which I have set to exclude ON) and it looks like it’s capturing Tweets to the database (with the wrong dates it seems) but not posting them to the blog (category ‘twitter’) (except for that @reply it wasn’t supposed to post to begin with).

    I have no idea what is going on. I’m scared that if I revert to 1.1b1, it just wont work, either.

Viewing 6 replies - 1 through 6 (of 6 total)
  • it seems to have posted an @reply (which I have set to exclude ON)

    What do you mean by “posted”?

    You may want to hit the “Reset Tweets” button after manually editing things in the db.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    I experienced this problem myself. The Exclude option is wholly broken. I could not get it to work at all with that option on, until I posted a reply, and then that one posted just fine.

    The exclude is backwards. When it’s on, it’s only letting replies through, not normal tweets. It did not work at all for me until I turned that option off. And I’m having to manually delete the reply posts.

    I tested it a bit on my dev server and confirmed this behavior. The Exclude Replies function is excluding non-replies instead. I suspect you have a ! where you shouldn’t or vice-verse. I tried to track it down, but that code is a giant tangle to me… 🙁

    Yeah, my experience now dictates that @reply excluding is working in REVERSE. The only Twitters that are posting now are @replies.

    re: ‘posted’, i don’t use the ‘sidebar’, i have TT post them as entries to the ‘twitter’ category. what i mean by ‘posted’ is, well, posted. (also, i do reset tweet checking, as well.)

    twitters are occurring in the database now but only @replies are getting posted to my site. looks like it works aside from the exclusion.

    Yeah, everything works fine with the Exclude @replies turned off.

    A possible fix for this has been checked in to SVN:

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    This fix appears to work, in that it definitely doesn’t post replies anymore. 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Twitter Tools No Longer Working’ is closed to new replies.