Support » Plugins » Twitter Tools Admin Options Page

  • I just upgraded a blog of mine to 2.7.1. After the upgrade, the Settings page for Twitter Tools now comes up empty, just a blank page. I’ve deactivated and reactivated the plugin. I’ve deactivated the plugin, deleted it from the plugins folder, loaded a backup copy, and re-activated the plugin. I’ve even bounced Apache on the server. Nothing has worked so far to bring the Settings page back.

    I’ve checked my ID and I’m an administrator, too, so that’s not it. It looks like the php is breaking somewhere as I never get a footer in the source code, it just ends after the contextual help accordion menu.

    I’ve got the exact same version of the plugin running on a sandbox domain with the same theme and the same copy of the WordPress core, and it’s having no problems with Twitter Tools. All of my other plugins are working and didn’t experience any issues with the upgrade, in the sense that all Settings pages are available in the admin area.

    Any ideas at all? This is just very weird…never seen this kind of behavior before.

Viewing 4 replies - 1 through 4 (of 4 total)
  • It looks like Twitter Tools creates its own table in your database called “wp_ak_twitter”.

    Maybe this got corrupted or damaged somehow? If you are totally deleting the plugin and uploading a fresh copy of the plugin, I’d suggest dropping that table so that you are starting totally from scratch.

    I thought about doing that, but…the plugin & widget are running just fine, still updating, just the way they’re supposed to be doing. It’s only the admin panel that’s gone / invisible / missing.

    EDITED TO ADD: Running in production just fine, that is. On my test bed, there are no issues with the admin page…it works A-OK.

    Well, I guess if ain’t broke, don’t fix it 🙂

    But before trying anything more tedious, I would say deleting the plugin and the plugin data and starting fresh would be the easiest potential fix.

    My (much smarter) colleague found the, or at least *a*, problem — it was a conflict with the 8.5.1 version of CFORMS. We don’t know what the conflict was, as it was a simple decision to ditch that completely, since it was unused and our “boss” was whining mightily about his dumb Twitter stuff. I’m still unclear on why it never showed up on the sandbox, and I might try to check it over there. But there you go, problem solved, at least at our site.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Twitter Tools Admin Options Page’ is closed to new replies.