Support » Plugins and Hacks » Twitter Tools » Twitter Tools 3.0 widget issues

Twitter Tools 3.0 widget issues

  • Further to my previous post, the widget for Twitter Tools 3.0 has two main problems:

    1) It is not updating the tweets (nothing from today for example), although I believe that to be a deeper problem.

    2) The “follow me on Twitter” link goes to the main Twitter site instead of my account and I can’t see any way to change that (or even remove it until it is fixed).

    I might have to hardcode it in the PHP directly.


Viewing 11 replies - 1 through 11 (of 11 total)
  • Oh, and …

    3) It is no longer possible for me to tweet from the widget.

    Plugin Contributor Alex King


    Sounds like you need to enable Twitter Tools for your chosen accounts.

    Sounds like you need to enable Twitter Tools for your chosen accounts.

    Oh, really? I just woke up, so a little caffeine is required, but let’s see …

    1) In the Social settings I have the account set to my only Twitter account (set as default).

    2) Broadcasting is on by default.

    3) No API key is set because @anywhere will be disabled in a couple of months and I don’t want to get used to it.

    4) Social’s comments display is disabled, I want comments to match my theme. When this is enabled I do see a jarringly different comment field.

    5) Fetch new comments is set to automatic. This is one of the things that does not work.

    6) Debug mode is on, but debug_log.txt is empty.

    7) My WordPress User Profile is also configured to my only Twitter account (set as default).

    8) In the Twitter Tools settings the show admin screens for tweets is set to yes.

    9) Create URLs for tweets is set to yes. The actual URL is different from the example, at least with the tweets converted from prior to TT3.0.

    10) TT3 credit link is active.

    11) Debug logging is enabled.

    12) Account configured in Social is no longer greyed out and the enable Twitter Tools option is checked.

    13) Create blogposts from tweets is checked (I hope this only creates the special tweet pages and not a real post on the main page). Retweets are excluded.

    14) Both the Social and Twitter Tools plugin directories are set with ownership of root.apache and permissions of 775.

    15) SELinux has been switched from enforcing mode to permissive while I troubleshoot this, but this plugin shouldn’t be doing anything that Apache, PHP and MySQL can’t already do.

    That’s everything that was set before I went to bed last night, so what have I overlooked?

    By the way, I have confirmed that MailChimp has app access in my Twitter account for Social. It would be nice to override this with a local API key at some point in the future, but let’s just get it working for now.

    Hi Ben,

    I’ve had this issue and seem to have solved it by going to the Twitter Tools Admin page (Settings -> Twitter Tools) and in the list of Twitter accounts, clicking one of them. This gave me a tick box I could tick… it’s hardly intuitive though!

    There’s actually three places that I’ve found to set it. One is in the Social settings, one is in the Twitter Tool settings and one is in the User profile settings. I’ve configured all three, I’m not sure if there’s anywhere else.

    Lots of steps to get this working again on my site after the move from 2.4 to 3.0, but I’m still not there 100%:

    • Installed and activated Social 2.5 and Twitter Tools 3
    • Linked to Twitter in Social and enabled the account in TT
    • Tested the broadcast functionality, but the default links were going to the wrong URL, so I signed up for a bit.ly key and installed the Bitly Shortlinks plugin (which fixed the links to posts)
    • Successfully converted the old database (10,000+ tweets) in about an hour
    • Added a do_shortcode line to my theme template, although I think the old function call would’ve worked after looking through the plugin code (I thought it wasn’t working, but I hadn’t enabled that account yet)
    • The list of tweets display is correctly excluding tweets that are created from broadcasts

    So now broadcasting works fine, but I’m not getting new tweets every 15 minutes. I tried tracing the cron calls in both plugins, but I can’t figure out exactly how it works. If I hit the button in the TT settings to manually download tweets, it works (but the downloading tweets message never goes away). I thought maybe it was permissions setting with Social, but I think that just relates to downloading social comments. I’ve also tried disabling and reenabling each plugin, but I still can’t get the auto-download of new tweets to work.

    Any suggestions on what else I should check?

    Not sure. I haven’t managed to get manually downloading tweets to work, which means the advanced cron method probably won’t work either. All I’ve got is the conversion of tweets from prior to the upgrade.

    @csogilvie thanks so much this fixed it for me. Hardly intuitive to say the least!:

    I’ve had this issue and seem to have solved it by going to the Twitter Tools Admin page (Settings -> Twitter Tools) and in the list of Twitter accounts, clicking one of them. This gave me a tick box I could tick… it’s hardly intuitive though!

    I have the latest version of both and didn’t realise there were so many changes to make since the upgrade.

    First problem is wiht Social. I can’t register any accounts and the buttons take me to a 404 page on my site. Surely this must have been well tested to work.

    Totally frustrated.

    Any ideas anyone?

    Until Twitter Tools starts working I have added these plugins:

    * Twitter Digest (will be keeping this because the digest function has been removed from Twitter Tools).
    * Rotating Tweets widget (which is really quite nifty and might become permanent).
    * Twitter Widget Pro (a normal widget, but can be a little flaky and is currently inactive).
    * Simple Twitter Connect (for tweeting new blog posts).

    As for getting Twitter Tools to work, I’m all out of ideas at the moment and Alex King, the plugin author, has only repeated that it works on his server. Some others here have had partial success with getting it to work and there are some reports of things to try in the other threads.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Twitter Tools 3.0 widget issues’ is closed to new replies.
Skip to toolbar