Support » Plugins and Hacks » [Resolved] Twitter Tools 1.6 – Digest (weekly/daily)

[Resolved] Twitter Tools 1.6 – Digest (weekly/daily)

  • Good day all.

    I upgraded to the new version of Twitter Tools recently – the betas and then the final release. In it I saw that the digest portion of the plug in appeared to be resolved so I left my weekly digest setting alone and checked back a few days later.

    Unfortunately nothing had posted. With each new version I tested the weekly digest by changing the day/time to the next day at 6:40 am. Nothing has posted.

      I have:

    • verified that the .php file is in the correct location.
    • updated the Twitter Tools settings.
    • manually ‘updated tweets’
    • turned off, updated, and then turned on the weekly digest and updated again

    It feels like I’ve at the error so much but I can’t see it because I’ve looked at it so much. Any suggestions on how to resolve this? Thanks.

Viewing 15 replies - 1 through 15 (of 38 total)
  • Bump… Anyone?

    I’ve got the same problem. Trying to do the daily digest. I’ve tried prety much the same things.

    Platform: Linux
    WP: 2.7.1
    TT: 2.6


    Sorry you’re still seeing problems with these features. They work great in our testing, so whatever you’re seeing is probably different than what we’ve been able to test.

    We’d be happy to try to debug this on your server if you like, but would ask that this be done at our normal consulting rates. Get in touch if you’d like to pursue this route.

    Thanks Alex. Sorry to hear you can’t get it working either ITJuggler.

    Are there any ideas out there to make this work?

    For those that have it working would you be willing to post your TT settings here to compare?

    Yep, was pleased that the new release came out so I set my weekly digest and nothing came out either.

    Sorry Alex but I’m not going to pay a consulting fee to have it fixed, I guess we’ll just have to wait disappointed until the next release.

    Am currently copying and pasting a weekly digest to my site instead, which is stupid.

    Platform: Linux
    WP: 2.7.1
    TT: 1.6

    Unfortunately we cannot test for all server configurations and potential plugin conflicts. We work very hard to release high quality (free) plugins; if anyone does want us to debug an issue for them, we are happy to do so as outlined above.

    Ok, been hunting down another plugin issue and hadn’t had a chance to get back to this..

    Error_log in the /wp-content/plugins/twitter-tools dir has..
    [02-Mar-2009 13:13:30] PHP Fatal error: Call to undefined function load_plugin_textdomain() in /home/oll49675/itjuggler/wp-content/plugins/twitter-tools/twitter-tools.php on line 30

    I’ve hunted around in a couple of other plugins, and CFORMS sets up load_plugin_textdomain thusly ..
    add_action(‘init’, create_function(”, ‘load_plugin_textdomain(\’cforms\’);’) );

    and SEO Tools calls it like..
    function init() {
    if (function_exists(‘load_plugin_textdomain’)) {
    load_plugin_textdomain(‘all_in_one_seo_pack’, ‘wp-content/plugins/all-in-one-seo-pack’);

    Trying some hacking on the code.. will report back shortly.

    Thanks for the update ITJuggler.

    Disabeling “All in one seo pack” did not seem to fix it…

    Thought it might benefit the discussion based on the idea that another plugin might be causing the issue. Here is a list of the plugins I have active:

    Akismet 2.2.3
    All in One SEO Pack 1.4.7
    Contact Form 7 1.9.3
    Flickr Photo Album 1.1
    Google XML Sitemaps 3.1.2
    Open Flash Chart Core 0.4
    Raz-Captcha 1.0
    Search Meter 2.5
    ShareThis 2.3
    StatCounter 0.1
    Twitter Tools 1.6
    Ultimate Google Analytics 1.6.0
    Wordbook 0.14.3
    WordPress.com Stats 1.3.7
    WordPress Database Backup 2.2.2
    WPG2 3.0.7
    WP Security Scan 2.3
    Year End Stats 0.4

    Akismet 2.2.3
    Google Analyticator 2.40
    Google XML Sitemaps 3.1.2
    One Click Plugin Updater 2.4.4
    Ozh’ Admin Drop Down Menu
    Smart Youtube 2.8.1
    Twitter Tools 1.6
    WoW Armory 2.4
    WP-Print 2.40
    WPtouch iPhone Theme 1.7.5
    (Disabeled atm) All in One SEO Pack 1.4.7
    (Disabeled) podPress 8.8.1

    But can addons create interference? Isn’t that bad plugin architecture? It would seem logical that wordpress did something to secure that plugins does not interfere with each other.

    And my server info:

    Operating system Linux
    Linux kernel version 2.6.27-grsec
    Apache version 2.2.11 (Unix)
    Perl version 5.8.8
    PHP version 5.2.8
    MySQL version 5.0.67-community-log
    Path to Perl /usr/bin/perl
    Path to sendmail /usr/sbin/sendmail

    It looks like disabeling All in One SEO Pack did fix the issue for me. However, it can also be (most likely not) becouse I flushed the settings and reinstalled tt (I removed all aktt_* enteries in the option database, and dropped the tweets database table (wich had all my tweets)).

    I think tt is having issues posting the Digest’s. Lets hope ak will test run it with All in One SEO Pack enabeled, and fix this issue. And I have a suggestion for a future; make tt able to compare its database of tweets, with the Digests it is supposed to be making. And make it awalable on demand (button in the config page).

    There is a tweet in the database with the date 13. January 09.
    Get the titeles that are supposed to go with this tweet (commonly: Twitter Updates for 2009-01-13)
    Search for posts with that exact title
    if match, check next tweet in the database
    else try to create digest, if error, display error and check next tweet

    I will look in to modefying the plugin, but I am no expert, and I hope ak or a person with plugin experience will look into it.

    I wish I had your luck sjefen6.

    I tried the following:

      deleted tt within wp
      deleted wp_ak_twitter from the db via phpmyadmin
      deleted aktt_ setting references from the db via phpmyadmin
      installed and activated tt 1.6 from within wp
      verified wp_ak_twitter was re-inserted into db via phpmyadmin
      saw 0 records in wp_ak_twitter via phpmyadmin
      configured tt within wp
      set weekly to a few minutes from present time
      clicked update tweets and reset tweet checking within wp
      verified 20 records were imported into the db via phpmyadmin
      neither daily or weekly digest posted

    Now, only 20 tweets are in the db. I’ve sat longer than 10 minutes and have not seen any additional tweets added to the db.

    One thing I learned testing tonight was that my server is now one hour off which is likely to to DST.

    …I looked at my Facebook profile and saw that a new blog had posted on my site this morning. That’s right, it worked. The weekly digest posted sometime this morning.

    It appears that a flush of TT settings, etc. from the db did work.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘[Resolved] Twitter Tools 1.6 – Digest (weekly/daily)’ is closed to new replies.