WordPress.org

Support

Support » Plugins and Hacks » Twitter Timeline

Twitter Timeline

  • Geezerjim
    Member

    @actorjiml

    When I entered the widget ID from Twitter and saved the Twitter Timeline widget that number changed (Added: to 2147483647). I understand that the old twitter widget is going away on May 7th. Will the new one not work until that time? Also, the Twitter Timeline shortcode shows the code when embeded in a a post, not the timeline.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 16 through 30 (of 43 total)
  • I’ve got it working again now. But perhaps there’s a way to remove the scroll bar on the timeline? You can see how cramped it looks in my little sidebar.

    http://jasonsmitharch.com/

    Just listing the last 3-5 tweets with the old twitter widget fit fine, but the scroll bar in the new one makes it look cramped

    daileycon
    Member

    @daileycon

    I was wondering the same thing. How to show only 3-5 tweets and no scroll bar!

    Having the same problem. Timeline only produces “My tweets”. Tried with 2 widgets I created via Twitter.

    anoveldianne
    Member

    @anoveldianne

    I just now updated my Jetpack to the latest version, made the new Twitter widget, followed all the directions I was given. Just showing something that says “My Tweets,” but none of the actual tweets. It’s now May 7th (at least on the East Coast). What am I doing wrong?

    Check your browser security settings. I have to turn off “Do Not Track Me” in Chrome in order to see the widget in action. Without turning it off, I just see “My Tweets,” too.

    glambergirl
    Member

    @glambergirl

    I’m very confused on how the new Twitter Timeline Widget is suppose to be added. HELP

    caseywfrancis
    Member

    @caseywfrancis

    My Twitter Timeline widget shows up when first loading on the page and then disappears.

    Gem City Gymnastics & Tumbling – Quincy, Illinois

    Log in to Twitter and go to Settings (in the menu with the gear icon).
    Click Widgets.
    Click “Create New.”
    Make changes if you want, but it won’t matter.
    Click “Save.”
    Copy the iframe code (it should already be highlighted for you).
    Paste it into any program (like notepad, word, even in an email).
    The first bit of it will look like this:

    <a class="twitter-timeline" href="https://twitter.com/xxxxxxxxxxxxx" data-widget-id="xxxxxxxxxxxxxxxxxxx">Tweets by @xxxxxxxxxxxxxxx</a>

    Copy the code that is between the quotation marks after “data-widget-id”.
    Log-in to your wordpress dashboard.
    Go to Appearances -> Widgets
    Drag the Jetpack Twitter Timeline widget to the sidebar/footer/section you want it to appear in.
    Type in a title if you want.
    Paste the ID you copied into the “Widget ID” field.
    Make any other changes and save.
    I have to allow cookies and unblock (from tracking) a site in order to see the widget properly.

    daileycon
    Member

    @daileycon

    Has anyone figured out why it shows “My tweets” half the time!!! Need a fix!

    I’ve determined that the problem only occurs for me in Chrome when I have Abine’s DoNotTrackMe extension enabled.

    anoveldianne
    Member

    @anoveldianne

    Thanks for the feedback. Unfortunately, none of the suggestions have worked. I have even reinstalled Chrome, turned of the “Do Not Track Me” thing, and created an entirely new widget with Twitter (more than once). What am I doing wrong?

    Also, the directions tell me just to paste the long number associated with the widget. That is what I have been doing. Should I be pasting that long code that tinamar is talking about?

    anoveldianne
    Member

    @anoveldianne

    Well, I got my new Twitter Timeline widget to finally show up on my blog, but it isn’t using the JetPack widget. On my WordPress dashboard, I went to Appearances –> Widgets and chose the one labeled “Text.” In the text box provided, I pasted the big long string of code that Twitter provided (not just the long number that the JetPack widget asks for). Worked immediately. So simple, I don’t why I didn’t think of it sooner. Another JetPack disappointment.

    daileycon
    Member

    @daileycon

    That’s the way to go! Use a text widget not jetpacks version and use these options:

    data-chrome=”noheader nofooter noborders transparent noscrollbar” data-tweet-limit=”3″

    Clean!

    Same problem here. A single WidgetID is displaying the widget on one website, but the same ID is displaying ‘My Tweets’ on another site. Actually both sites are just different setups of a single site (development/live sites), so they are using exactly same code/theme.

    I have found what is causing the issue in my case.
    This widget, en-queues the twitter script using a protocol relative url. And I am using bwp-minify plugin, which apparently doesn’t support protocol relative urls, so it doesn’t include widget.js script!

    As a fix, I have added the following line to my functions.php which registers the script with an absolute url:

    wp_register_script( 'twitter-widgets', 'http://platform.twitter.com/widgets.js', '', '', true );
Viewing 15 replies - 16 through 30 (of 43 total)
  • The topic ‘Twitter Timeline’ is closed to new replies.