WordPress.org

Support

Twitter Timeline

  • When I entered the widget ID from Twitter and saved the Twitter Timeline widget that number changed (Added: to 2147483647). I understand that the old twitter widget is going away on May 7th. Will the new one not work until that time? Also, the Twitter Timeline shortcode shows the code when embeded in a a post, not the timeline.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 43 total)
  • I’m seeing the same thing, on this site: http://blogs.kentlaw.iit.edu/library/

    The original Jetpack Twitter widget is (at the moment) working correctly.
    The new Jetpack Twitter Timeline widget is below it, and just has a link that says “My Tweets” but doesn’t link back to the account or anything else.

    When I save, it switches the ID from 329612247032795136 to the same ID as Geezerjim mentions (2147483647). I’ve tried deleting the widget and starting again and it still doesn’t allow me to enter the code correctly.

    Note: I’ve reviewed the known issues page, troubleshooting tips, and gone over the support page for this widget several times to see if any of the existing documentation would help solve it.

    Twitter Timeline Widget

    Since I’m seeing the issue from the widgets page, I can’t imagine that fiddling with different themes would make much difference. I know I’m using the latest version of WordPress and Jetpack and there aren’t any old plugins installed or enabled to conflict.

    I’m going to go ahead and submit an internal ticket to this page, as mentioned in the JetPack support “sticky post”:
    Contact

    I’m seeing this error with Twenty-twelve as my theme, so I can’t see that being an issue either. I’ll keep checking here since I am at work.

    The update to 2.2.5 appears to have worked for the widget, but the shortcode in a post still doesn’t show correctly.

    Noticed something else since the change to 2.2.5 – The links on the text in the widget are now showing: You need to <a href="https://twitter.com/settings/widgets/new/user" target="_blank">create a widget at Twitter.com</a>, and then enter your widget id (the long number found in the URL of your widget's config page) in the field below. <a href="http://support.wordpress.com/widgets/twitter-timeline-widget/" target="_blank">Read more</a>.

    I just upgraded to 2.2.5 this evening and it crashed my site? I had to disable the plugin to get back up. I have used 2.2 for about 6 months with no issues…is there a way to go back?

    Same here, just updated and tweets won’t load. Put in the old twitter widget and it works fine. Twitter Timeline needs work before May 7th!

    Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    Thank you all for the reports.

    I tried to reproduce the issue, but the widgets were displayed properly on my end. I did notice the problem mentioned by @Geezerjim though, and we’re looking into it right now.

    Could you all try to create a new widget on Twitter, and let me know if it helps?
    https://twitter.com/settings/widgets/new/user

    Also, as @Geezerjim mentioned, could you all make sure you’re running the latest version of the jetpack plugin?

    Thanks, Jeremy – I followed the notes you’ve sent and it’s currently working fine for me. I did find that rearranging my widgets temporarily switched it back to the “My Tweets” broken link, but I was able to paste in the correct widget ID code, save it successfully, and it’s back to normal.

    Not sure about the glitchiness, but I’ll watch carefully to see if I run into any other problems and report back. Of course I’ll also make sure all of my wordpress sites have Jetpack up to date as I switch out the rest of our twitter widgets.

    I don’t know how much difference it would make for anything, but all my sites are running on WIMP servers – it generally doesn’t cause any problems for this kind of stuff, but it’s the only major difference in our configuration from most people that I can think of.

    I just updated Jetpack to 2.2.5 and created a new Twitter widget for this purpose, and am also getting a blank timeline. The old widget still displays tweets. I also tried to use the shortcode in a new post, and the shortcode was not processed (the shortcode was output onto the post). This is the entire output from the Jetpack Twitter Timeline widget:

    <li id="twitter_timeline-2" class="widget-container widget_twitter_timeline"><h3 class="widget-title">Twitter Updates</h3><a class="twitter-timeline" data-widget-id="[my id]" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-chrome="noheader nofooter noborders transparent" width="200" height="400" lang="EN">My Tweets</a></li>

    My twitter timeline only showed the dead link of My Tweets as well. When I clicked on No Header and previewed my site the twitter timeline then appeared. I went back and deselected No Header and my Twitter Timeline continued to work. I have no idea why this fixed it.

    Ignore the previous post my Twitter Timeline is back to showing the dead link My Tweets. My timeline was working for about 15 seconds.

    Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    @technum @nwgfoa Could you both let me know your timeline ID, so I can try to reproduce the problem?

    I updated Jetpack and replaced the old twitter widget with twitter timeline. It worked at first but I didn’t like the way it looked so I tried to remove it. It did not go away despite removing it from the sidebar in my dashboard. I tried deleting the widget at twitter and now I have a dead ‘My Tweets’ link stuck in my sidebar.

    I tried making a new widget and adding it but it never showed up, only the old dead link still. How do I get rid of it?

    Plugin Author Jeremy Herve

    @jeherve

    Jetpack Mechanic

    @jason Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    Contact

Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘Twitter Timeline’ is closed to new replies.
Skip to toolbar