WordPress.org

Forums

Jetpack by WordPress.com
Twitter Timeline (44 posts)

  1. Geezerjim
    Member
    Posted 2 years ago #

    When I entered the widget ID from Twitter and saved the Twitter Timeline widget that number changed (Added: to 2147483647). I understand that the old twitter widget is going away on May 7th. Will the new one not work until that time? Also, the Twitter Timeline shortcode shows the code when embeded in a a post, not the timeline.

    http://wordpress.org/extend/plugins/jetpack/

  2. Emily Barney
    Member
    Posted 2 years ago #

    I'm seeing the same thing, on this site: http://blogs.kentlaw.iit.edu/library/

    The original Jetpack Twitter widget is (at the moment) working correctly.
    The new Jetpack Twitter Timeline widget is below it, and just has a link that says "My Tweets" but doesn't link back to the account or anything else.

    When I save, it switches the ID from 329612247032795136 to the same ID as Geezerjim mentions (2147483647). I've tried deleting the widget and starting again and it still doesn't allow me to enter the code correctly.

  3. Emily Barney
    Member
    Posted 2 years ago #

    Note: I've reviewed the known issues page, troubleshooting tips, and gone over the support page for this widget several times to see if any of the existing documentation would help solve it.

    http://en.support.wordpress.com/widgets/twitter-timeline-widget/

    Since I'm seeing the issue from the widgets page, I can't imagine that fiddling with different themes would make much difference. I know I'm using the latest version of WordPress and Jetpack and there aren't any old plugins installed or enabled to conflict.

    I'm going to go ahead and submit an internal ticket to this page, as mentioned in the JetPack support "sticky post":
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  4. Geezerjim
    Member
    Posted 2 years ago #

    I'm seeing this error with Twenty-twelve as my theme, so I can't see that being an issue either. I'll keep checking here since I am at work.

  5. Geezerjim
    Member
    Posted 2 years ago #

    The update to 2.2.5 appears to have worked for the widget, but the shortcode in a post still doesn't show correctly.

  6. Geezerjim
    Member
    Posted 2 years ago #

    Noticed something else since the change to 2.2.5 - The links on the text in the widget are now showing: You need to <a href="https://twitter.com/settings/widgets/new/user" target="_blank">create a widget at Twitter.com</a>, and then enter your widget id (the long number found in the URL of your widget's config page) in the field below. <a href="http://support.wordpress.com/widgets/twitter-timeline-widget/" target="_blank">Read more</a>.

  7. starrman62
    Member
    Posted 2 years ago #

    I just upgraded to 2.2.5 this evening and it crashed my site? I had to disable the plugin to get back up. I have used 2.2 for about 6 months with no issues...is there a way to go back?

  8. daileycon
    Member
    Posted 2 years ago #

    Same here, just updated and tweets won't load. Put in the old twitter widget and it works fine. Twitter Timeline needs work before May 7th!

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    Thank you all for the reports.

    I tried to reproduce the issue, but the widgets were displayed properly on my end. I did notice the problem mentioned by @Geezerjim though, and we're looking into it right now.

    Could you all try to create a new widget on Twitter, and let me know if it helps?
    https://twitter.com/settings/widgets/new/user

    Also, as @Geezerjim mentioned, could you all make sure you're running the latest version of the jetpack plugin?

  10. Emily Barney
    Member
    Posted 2 years ago #

    Thanks, Jeremy - I followed the notes you've sent and it's currently working fine for me. I did find that rearranging my widgets temporarily switched it back to the "My Tweets" broken link, but I was able to paste in the correct widget ID code, save it successfully, and it's back to normal.

    Not sure about the glitchiness, but I'll watch carefully to see if I run into any other problems and report back. Of course I'll also make sure all of my wordpress sites have Jetpack up to date as I switch out the rest of our twitter widgets.

    I don't know how much difference it would make for anything, but all my sites are running on WIMP servers - it generally doesn't cause any problems for this kind of stuff, but it's the only major difference in our configuration from most people that I can think of.

  11. technum
    Member
    Posted 2 years ago #

    I just updated Jetpack to 2.2.5 and created a new Twitter widget for this purpose, and am also getting a blank timeline. The old widget still displays tweets. I also tried to use the shortcode in a new post, and the shortcode was not processed (the shortcode was output onto the post). This is the entire output from the Jetpack Twitter Timeline widget:

    <li id="twitter_timeline-2" class="widget-container widget_twitter_timeline"><h3 class="widget-title">Twitter Updates</h3><a class="twitter-timeline" data-widget-id="[my id]" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-chrome="noheader nofooter noborders transparent" width="200" height="400" lang="EN">My Tweets</a></li>

  12. NWGFOA
    Member
    Posted 2 years ago #

    My twitter timeline only showed the dead link of My Tweets as well. When I clicked on No Header and previewed my site the twitter timeline then appeared. I went back and deselected No Header and my Twitter Timeline continued to work. I have no idea why this fixed it.

  13. NWGFOA
    Member
    Posted 2 years ago #

    Ignore the previous post my Twitter Timeline is back to showing the dead link My Tweets. My timeline was working for about 15 seconds.

  14. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    @technum @NWGFOA Could you both let me know your timeline ID, so I can try to reproduce the problem?

  15. Jason Smith
    Member
    Posted 2 years ago #

    I updated Jetpack and replaced the old twitter widget with twitter timeline. It worked at first but I didn't like the way it looked so I tried to remove it. It did not go away despite removing it from the sidebar in my dashboard. I tried deleting the widget at twitter and now I have a dead 'My Tweets' link stuck in my sidebar.

    I tried making a new widget and adding it but it never showed up, only the old dead link still. How do I get rid of it?

  16. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    @Jason Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  17. Jason Smith
    Member
    Posted 2 years ago #

    I've got it working again now. But perhaps there's a way to remove the scroll bar on the timeline? You can see how cramped it looks in my little sidebar.

    http://jasonsmitharch.com/

    Just listing the last 3-5 tweets with the old twitter widget fit fine, but the scroll bar in the new one makes it look cramped

  18. daileycon
    Member
    Posted 2 years ago #

    I was wondering the same thing. How to show only 3-5 tweets and no scroll bar!

  19. iso500
    Member
    Posted 2 years ago #

    Having the same problem. Timeline only produces "My tweets". Tried with 2 widgets I created via Twitter.

  20. anoveldianne
    Member
    Posted 2 years ago #

    I just now updated my Jetpack to the latest version, made the new Twitter widget, followed all the directions I was given. Just showing something that says "My Tweets," but none of the actual tweets. It's now May 7th (at least on the East Coast). What am I doing wrong?

  21. tinamar
    Member
    Posted 2 years ago #

    Check your browser security settings. I have to turn off "Do Not Track Me" in Chrome in order to see the widget in action. Without turning it off, I just see "My Tweets," too.

  22. glambergirl
    Member
    Posted 2 years ago #

    I'm very confused on how the new Twitter Timeline Widget is suppose to be added. HELP

  23. caseywfrancis
    Member
    Posted 2 years ago #

    My Twitter Timeline widget shows up when first loading on the page and then disappears.

    http://gemcitygymnasticsandtumbling.com/home/

  24. tinamar
    Member
    Posted 2 years ago #

    Log in to Twitter and go to Settings (in the menu with the gear icon).
    Click Widgets.
    Click "Create New."
    Make changes if you want, but it won't matter.
    Click "Save."
    Copy the iframe code (it should already be highlighted for you).
    Paste it into any program (like notepad, word, even in an email).
    The first bit of it will look like this:

    <a class="twitter-timeline" href="https://twitter.com/xxxxxxxxxxxxx" data-widget-id="xxxxxxxxxxxxxxxxxxx">Tweets by @xxxxxxxxxxxxxxx</a>

    Copy the code that is between the quotation marks after "data-widget-id".
    Log-in to your wordpress dashboard.
    Go to Appearances -> Widgets
    Drag the Jetpack Twitter Timeline widget to the sidebar/footer/section you want it to appear in.
    Type in a title if you want.
    Paste the ID you copied into the "Widget ID" field.
    Make any other changes and save.
    I have to allow cookies and unblock (from tracking) a site in order to see the widget properly.

  25. daileycon
    Member
    Posted 2 years ago #

    Has anyone figured out why it shows "My tweets" half the time!!! Need a fix!

  26. technum
    Member
    Posted 2 years ago #

    I've determined that the problem only occurs for me in Chrome when I have Abine's DoNotTrackMe extension enabled.

  27. anoveldianne
    Member
    Posted 2 years ago #

    Thanks for the feedback. Unfortunately, none of the suggestions have worked. I have even reinstalled Chrome, turned of the "Do Not Track Me" thing, and created an entirely new widget with Twitter (more than once). What am I doing wrong?

    Also, the directions tell me just to paste the long number associated with the widget. That is what I have been doing. Should I be pasting that long code that tinamar is talking about?

  28. anoveldianne
    Member
    Posted 2 years ago #

    Well, I got my new Twitter Timeline widget to finally show up on my blog, but it isn't using the JetPack widget. On my WordPress dashboard, I went to Appearances --> Widgets and chose the one labeled "Text." In the text box provided, I pasted the big long string of code that Twitter provided (not just the long number that the JetPack widget asks for). Worked immediately. So simple, I don't why I didn't think of it sooner. Another JetPack disappointment.

  29. daileycon
    Member
    Posted 2 years ago #

    That's the way to go! Use a text widget not jetpacks version and use these options:

    data-chrome="noheader nofooter noborders transparent noscrollbar" data-tweet-limit="3"

    Clean!

  30. Parham
    Member
    Posted 2 years ago #

    Same problem here. A single WidgetID is displaying the widget on one website, but the same ID is displaying 'My Tweets' on another site. Actually both sites are just different setups of a single site (development/live sites), so they are using exactly same code/theme.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic